aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-10-18 10:15:06 +0200
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-10-18 10:15:06 +0200
commit5c0558adc5b6ea67b60633a7a5c948ae3e29d2ea (patch)
tree0d584e50c53a57d4510bf998b9a8fb6285db93ea /dev-python/sniffio
parentdev-python/trio: version bump 0.17.0 (diff)
downloadguru-5c0558adc5b6ea67b60633a7a5c948ae3e29d2ea.tar.gz
guru-5c0558adc5b6ea67b60633a7a5c948ae3e29d2ea.tar.bz2
guru-5c0558adc5b6ea67b60633a7a5c948ae3e29d2ea.zip
dev-python/sniffio: version bump 1.2.0
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'dev-python/sniffio')
-rw-r--r--dev-python/sniffio/Manifest2
-rw-r--r--dev-python/sniffio/sniffio-1.2.0.ebuild (renamed from dev-python/sniffio/sniffio-1.1.0.ebuild)5
2 files changed, 6 insertions, 1 deletions
diff --git a/dev-python/sniffio/Manifest b/dev-python/sniffio/Manifest
index 6a1b47b5c..daec3e147 100644
--- a/dev-python/sniffio/Manifest
+++ b/dev-python/sniffio/Manifest
@@ -1 +1 @@
-DIST sniffio-1.1.0.tar.gz 15285 BLAKE2B fc2887150c8b64cc9ba5eb261d2f04650033279e5b5a6527f28fa8eff6cda409ffddb0986bba1358288fd35e0bbd09d90a7c4a0893a612f1efdbec393c2d9e3c SHA512 f315c79245ccec8e1e6e0f8ffe4cf42fdab7f5fe3e680ddc05c65732a6d26989ac1459135f13938380928b02802bc0a6b1174c83118a60b0ad15f59730927912
+DIST sniffio-1.2.0.tar.gz 17132 BLAKE2B d42442a231c07834803e8552812dc177defbc0d062418fa576e7368a973eaa1ea20e4933e145a26178a707da72fb00529b19d44ea850f0a14c78bb2b5dab0d9a SHA512 96da4e0f0fff99b122aa729da052e97c2dd75f19aab4dd3728f8e337875b0fac1b3d8d96c8c3a67ca96f15dbf07a593b89e323bf04a8ee0501d7414454030719
diff --git a/dev-python/sniffio/sniffio-1.1.0.ebuild b/dev-python/sniffio/sniffio-1.2.0.ebuild
index ca0f46b1b..ad474c26d 100644
--- a/dev-python/sniffio/sniffio-1.1.0.ebuild
+++ b/dev-python/sniffio/sniffio-1.2.0.ebuild
@@ -22,3 +22,8 @@ DEPEND="test? ( dev-python/curio[${PYTHON_USEDEP}] )"
distutils_enable_sphinx docs/source dev-python/sphinxcontrib-trio
distutils_enable_tests pytest
+
+python_test() {
+ PYTHONPATH="${S}"
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}