aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-08-29 14:42:06 +0200
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-08-29 14:42:06 +0200
commit2b0cf5abf1d1c2c15c43b5aad02f031224808504 (patch)
tree97956ed0f0365f4c3867a3749d65c35b7a0d99a4 /dev-python/spotipy/spotipy-2.13.0.ebuild
parentdev-util/quilttools: Add patch and bump python version (diff)
downloadguru-2b0cf5abf1d1c2c15c43b5aad02f031224808504.tar.gz
guru-2b0cf5abf1d1c2c15c43b5aad02f031224808504.tar.bz2
guru-2b0cf5abf1d1c2c15c43b5aad02f031224808504.zip
dev-python/spotipy: version bump 2.14.0
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'dev-python/spotipy/spotipy-2.13.0.ebuild')
-rw-r--r--dev-python/spotipy/spotipy-2.13.0.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/spotipy/spotipy-2.13.0.ebuild b/dev-python/spotipy/spotipy-2.13.0.ebuild
deleted file mode 100644
index 6a64b518b..000000000
--- a/dev-python/spotipy/spotipy-2.13.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8,9} )
-
-inherit distutils-r1
-
-DESCRIPTION="A light weight Python library for the Spotify Web API"
-HOMEPAGE="https://spotipy.readthedocs.io
- https://github.com/plamere/spotipy"
-SRC_URI="https://github.com/plamere/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-IUSE="examples"
-
-LICENSE="MIT"
-KEYWORDS="~amd64 ~x86 "
-SLOT="0"
-
-RDEPEND="
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-
-DEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )"
-
-distutils_enable_sphinx docs
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # this test requires user credentials
- rm tests/integration/test_user_endpoints.py || die
-
- # this test requires a spotify client ID
- rm tests/integration/test_non_user_endpoints.py || die
-
- # need internet access
- sed -i -e 's:test_spotify_client_credentials_get_access_token:_&:' \
- tests/unit/test_oauth.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- pytest -vv tests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use examples && dodoc -r examples
-
- distutils-r1_python_install_all
-}