summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2018-12-28 18:54:07 +0100
committerFabian Groffen <grobian@gentoo.org>2018-12-28 18:54:07 +0100
commit98e32c25f969eb621e10f5703b41f6085d21cc0c (patch)
tree4cc25e58d038c0ae30d5cf40040f197b1229dda7
parentdev-libs/openssl: sync 1.1.0j (diff)
downloadprefix-98e32c25f969eb621e10f5703b41f6085d21cc0c.tar.gz
prefix-98e32c25f969eb621e10f5703b41f6085d21cc0c.tar.bz2
prefix-98e32c25f969eb621e10f5703b41f6085d21cc0c.zip
dev-libs/libgcrypt: cleanup
Package-Manager: Portage-2.3.52.2-prefix, Repoman-2.3.12 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
-rw-r--r--dev-libs/libgcrypt/Manifest2
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.8.1.ebuild82
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.8.2-r2.ebuild86
3 files changed, 0 insertions, 170 deletions
diff --git a/dev-libs/libgcrypt/Manifest b/dev-libs/libgcrypt/Manifest
index de5ea41b06..1b337719f4 100644
--- a/dev-libs/libgcrypt/Manifest
+++ b/dev-libs/libgcrypt/Manifest
@@ -1,3 +1 @@
-DIST libgcrypt-1.8.1.tar.bz2 2967344 BLAKE2B f259d08427f76238576e3897a821d457b6ff47c99716301b54b20a21ae7574a7ef1f4aa62947c443efb8274d5cb3d64dc1d9c4ea45568f6df6f29c2c1717860b SHA512 27c9d2fd9cba5afca71d421c9299d6942463975fae0bd10d4ff42cda2d7ea213e6b73c071a40fcf23ff52a93394cc7505ab332f8a4a3321826460e471eda5b4e
-DIST libgcrypt-1.8.2.tar.bz2 2966534 BLAKE2B 1a0768dc1c4fc64913256575ec9ebe77fe8c4297c648972c93865271f0a18e60954d2f37c264bad5f1941b5e80753f34349ded9626e5c26ab469cc076da9ac2e SHA512 1e8c414f95bf6b50e778102ca7c1b3b1f30d8320826d9fff747a0a098ef85499cdc3e6de736853b9cd4e5dadda35c7c0a291e13643dcac5eaef44f2ddc7a6c09
DIST libgcrypt-1.8.4.tar.bz2 2990108 BLAKE2B 97a1f9382adf23cd4ac491a392882f2e712fddd4f0d95a4fafb9cc70aa41ffa7b7b6a371b8368e9c99e3e1849b9d38078abc55703d4d8b25289f3c662e6ba8a1 SHA512 b831fc337eb14806897e224b0d1e78d1f8e9db91dffa818a015a4aa104144e2d971e5a855904907ee2bb9990a9d526de32d6787e1cae98e28a65c3258b2b1ea1
diff --git a/dev-libs/libgcrypt/libgcrypt-1.8.1.ebuild b/dev-libs/libgcrypt/libgcrypt-1.8.1.ebuild
deleted file mode 100644
index 00233a5c4d..0000000000
--- a/dev-libs/libgcrypt/libgcrypt-1.8.1.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools flag-o-matic ltprune multilib-minimal
-
-DESCRIPTION="General purpose crypto library based on the code used in GnuPG"
-HOMEPAGE="http://www.gnupg.org/"
-SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1 MIT"
-SLOT="0/20" # subslot = soname major version
-KEYWORDS="~ppc-aix ~x64-cygwin ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc static-libs"
-
-RDEPEND=">=dev-libs/libgpg-error-1.25[${MULTILIB_USEDEP}]
- abi_x86_32? (
- !<=app-emulation/emul-linux-x86-baselibs-20131008-r19
- !app-emulation/emul-linux-x86-baselibs[-abi_x86_32]
- )"
-DEPEND="${RDEPEND}
- doc? ( virtual/texi2dvi )"
-
-DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.6.1-uscore.patch
- "${FILESDIR}"/${PN}-multilib-syspath.patch
-)
-
-MULTILIB_CHOST_TOOLS=(
- /usr/bin/libgcrypt-config
-)
-
-src_prepare() {
- # missing attribute(sysv_abi) for Cygwin?
- [[ ${CHOST} == *-cygwin* ]] && rm -f mpi/*/*.S
- default
- # always use -no-undefined even if upstream is not convinced yet
- sed -i -e 's/^no_undefined\s*=\s*$/& -no-undefined/' src/Makefile.am || die
- eautoreconf
-}
-
-multilib_src_configure() {
- if [[ ${CHOST} == *86*-solaris* ]] ; then
- # ASM code uses GNU ELF syntax, divide in particular, we need to
- # allow this via ASFLAGS, since we don't have a flag-o-matic
- # function for that, we'll have to abuse cflags for this
- append-cflags -Wa,--divide
- fi
- local myeconfargs=(
- --disable-dependency-tracking
- --enable-noexecstack
- --disable-O-flag-munging
- $(use_enable static-libs static)
-
- # disabled due to various applications requiring privileges
- # after libgcrypt drops them (bug #468616)
- --without-capabilities
-
- $([[ ${CHOST} == sparcv9-*-solaris* ]] && echo "--disable-asm")
- # no cygwin patch yet
- $([[ ${CHOST} == *-cygwin* ]] && echo gcry_cv_gcc_win64_platform_as_ok=no)
- )
- ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
-}
-
-multilib_src_compile() {
- default
- multilib_is_native_abi && use doc && VARTEXFONTS="${T}/fonts" emake -C doc gcrypt.pdf
-}
-
-multilib_src_install() {
- emake DESTDIR="${D}" install
- multilib_is_native_abi && use doc && dodoc doc/gcrypt.pdf
-}
-
-multilib_src_install_all() {
- default
- prune_libtool_files
-}
diff --git a/dev-libs/libgcrypt/libgcrypt-1.8.2-r2.ebuild b/dev-libs/libgcrypt/libgcrypt-1.8.2-r2.ebuild
deleted file mode 100644
index a4fd7956f7..0000000000
--- a/dev-libs/libgcrypt/libgcrypt-1.8.2-r2.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools flag-o-matic ltprune multilib-minimal toolchain-funcs
-
-DESCRIPTION="General purpose crypto library based on the code used in GnuPG"
-HOMEPAGE="http://www.gnupg.org/"
-SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1 MIT"
-SLOT="0/20" # subslot = soname major version
-KEYWORDS="~ppc-aix ~x64-cygwin ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc o-flag-munging static-libs"
-
-RDEPEND=">=dev-libs/libgpg-error-1.25[${MULTILIB_USEDEP}]
- abi_x86_32? (
- !<=app-emulation/emul-linux-x86-baselibs-20131008-r19
- !app-emulation/emul-linux-x86-baselibs[-abi_x86_32]
- )"
-DEPEND="${RDEPEND}
- doc? ( virtual/texi2dvi )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.6.1-uscore.patch
- "${FILESDIR}"/${PN}-multilib-syspath.patch
-)
-
-MULTILIB_CHOST_TOOLS=(
- /usr/bin/libgcrypt-config
-)
-
-src_prepare() {
- # missing attribute(sysv_abi) for Cygwin?
- [[ ${CHOST} == *-cygwin* ]] && rm -f mpi/*/*.S
- default
- # always use -no-undefined even if upstream is not convinced yet
- sed -i -e 's/^no_undefined\s*=\s*$/& -no-undefined/' src/Makefile.am || die
- eautoreconf
-}
-
-multilib_src_configure() {
- if [[ ${CHOST} == *86*-solaris* ]] ; then
- # ASM code uses GNU ELF syntax, divide in particular, we need to
- # allow this via ASFLAGS, since we don't have a flag-o-matic
- # function for that, we'll have to abuse cflags for this
- append-cflags -Wa,--divide
- fi
- local myeconfargs=(
- --disable-dependency-tracking
- --enable-noexecstack
- $(use_enable o-flag-munging)
- $(use_enable static-libs static)
-
- # disabled due to various applications requiring privileges
- # after libgcrypt drops them (bug #468616)
- --without-capabilities
-
- # http://trac.videolan.org/vlc/ticket/620
- # causes bus-errors on sparc64-solaris
- $([[ ${CHOST} == *86*-darwin* ]] && echo "--disable-asm")
- $([[ ${CHOST} == sparcv9-*-solaris* ]] && echo "--disable-asm")
- # no cygwin patch yet
- $([[ ${CHOST} == *-cygwin* ]] && \
- echo "gcry_cv_gcc_win64_platform_as_ok=no")
-
- GPG_ERROR_CONFIG="${EPREFIX}/usr/bin/${CHOST}-gpg-error-config"
- )
- ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
-}
-
-multilib_src_compile() {
- default
- multilib_is_native_abi && use doc && VARTEXFONTS="${T}/fonts" emake -C doc gcrypt.pdf
-}
-
-multilib_src_install() {
- emake DESTDIR="${D}" install
- multilib_is_native_abi && use doc && dodoc doc/gcrypt.pdf
-}
-
-multilib_src_install_all() {
- default
- prune_libtool_files
-}