summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-22 03:12:23 +0100
committerSam James <sam@gentoo.org>2022-05-22 03:30:10 +0100
commit13ca6d2b2253ab17db68572553f3b4ed34450fd3 (patch)
tree45c4e74f5d7cda192e98fd816f1379a688f427b2
parentsys-apps/hwdata: add 0.359 (diff)
downloadgentoo-13ca6d2b2253ab17db68572553f3b4ed34450fd3.tar.gz
gentoo-13ca6d2b2253ab17db68572553f3b4ed34450fd3.tar.bz2
gentoo-13ca6d2b2253ab17db68572553f3b4ed34450fd3.zip
sys-auth/ssh-ldap-pubkey: add 1.4.0
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-auth/ssh-ldap-pubkey/Manifest1
-rw-r--r--sys-auth/ssh-ldap-pubkey/ssh-ldap-pubkey-1.4.0.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/sys-auth/ssh-ldap-pubkey/Manifest b/sys-auth/ssh-ldap-pubkey/Manifest
index 2316da6720b1..fcc55b832db2 100644
--- a/sys-auth/ssh-ldap-pubkey/Manifest
+++ b/sys-auth/ssh-ldap-pubkey/Manifest
@@ -1 +1,2 @@
DIST ssh-ldap-pubkey-1.3.3.tar.gz 15389 BLAKE2B 24c741646e33cf7af400053eff17efa35b96ec418d1c2b8c370a371dde51fdbbb3af3423f0cc4374f61b302f9836601444ee72613388fa2d4445957f918d64f9 SHA512 b52d4de3e0704817e8ea0fb316c21646da1bac74ed226812c03f9ee5ae449a86e5ef4c679633d212db05382e216b254a185e29d4a2244318ad5de288b909254a
+DIST ssh-ldap-pubkey-1.4.0.tar.gz 15461 BLAKE2B 8e78fd6a5fa76ca97e813c95c9cbfefc3d40024cb31b8992de0c44770592f5abc7d8f0a4673905456dbe9a4272c1ce9a9e12bec69d9f8fa2f32a9b7a1895b978 SHA512 a62929b47f46f18936fcc7c233afaee43f0cef5f7a8de15304986205f98c2644a18f9c0dcabb35598f1cc485b8c4dbeb8b2f07cb2c3dcbb6b271a276aebf88e7
diff --git a/sys-auth/ssh-ldap-pubkey/ssh-ldap-pubkey-1.4.0.ebuild b/sys-auth/ssh-ldap-pubkey/ssh-ldap-pubkey-1.4.0.ebuild
new file mode 100644
index 000000000000..f47d13393d96
--- /dev/null
+++ b/sys-auth/ssh-ldap-pubkey/ssh-ldap-pubkey-1.4.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Utility to manage SSH public keys stored in LDAP"
+HOMEPAGE="https://github.com/jirutka/ssh-ldap-pubkey"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/jirutka/${PN}/${PN}.git"
+
+ inherit git-r3
+else
+ SRC_URI="https://github.com/jirutka/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="schema"
+
+MY_CDEPEND="dev-python/docopt[${PYTHON_USEDEP}]
+ >=dev-python/python-ldap-3.0[${PYTHON_USEDEP}]
+ virtual/logger"
+DEPEND="${MY_CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-describe[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )"
+
+# We need to block previous net-misc/openssh packages
+# to avoid file collision on "/etc/openldap/schema/openssh-lpk.schema"
+RDEPEND="${MY_CDEPEND}
+ schema? ( !net-misc/openssh[ldap(-)] )"
+
+DOCS=( README.md CHANGELOG.adoc )
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use schema; then
+ insinto /etc/openldap/schema
+ doins etc/openssh-lpk.schema
+ fi
+
+ local MY_DOCDIR="/usr/share/doc/${PF}/examples"
+ insinto "${MY_DOCDIR}"
+ doins etc/ldap.conf
+
+ # We don't want to compress this small file to allow user
+ # to diff configuration against upstream's default
+ docompress -x "${MY_DOCDIR}"
+}