summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-03-21 21:49:18 +0200
committerMart Raudsepp <leio@gentoo.org>2019-03-21 21:51:55 +0200
commit2d63589eeac2d9a551f30bb7a7b3fd62620669ed (patch)
tree2668f3be494f3dc9b8fece21338de5cb26aab335
parentx11-libs/gtksourceview: bump to 3.24.10 (diff)
downloadgentoo-2d63589eeac2d9a551f30bb7a7b3fd62620669ed.tar.gz
gentoo-2d63589eeac2d9a551f30bb7a7b3fd62620669ed.tar.bz2
gentoo-2d63589eeac2d9a551f30bb7a7b3fd62620669ed.zip
x11-libs/gtksourceview: bump to 4.2.0
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
-rw-r--r--x11-libs/gtksourceview/Manifest1
-rw-r--r--x11-libs/gtksourceview/gtksourceview-4.2.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/x11-libs/gtksourceview/Manifest b/x11-libs/gtksourceview/Manifest
index 8de32b575b7f..038e9609ebdf 100644
--- a/x11-libs/gtksourceview/Manifest
+++ b/x11-libs/gtksourceview/Manifest
@@ -3,3 +3,4 @@ DIST gtksourceview-3.24.10.tar.xz 1422888 BLAKE2B df344049095a354d49474d0ff0ae9d
DIST gtksourceview-3.24.8.tar.xz 1408964 BLAKE2B e406aa9f776821abfcc87333fc955b4f3ae334f73a8b1dfa0b123067df24bd4f473e326347c99df7dc6c97adbdde8739cb301e45ca70324f6e8de2ce9e1ea973 SHA512 84a02278344f9fe3c1b8f2440c6179feaea53df93061c63023d92bcaa1ec7ff8e95e1f3a463c23d8487c74492469f3dc367bcca3975ef169bf03925ecee7f7ff
DIST gtksourceview-3.24.9.tar.xz 1414444 BLAKE2B 9d148fba03339c7dccca70822f498aea6423125af1a954e0c9f8ff9735141fc9e4f845c7172be5faf97e694445dc95d41d5d903ef5b5da3dd0ce7fe58b524ca7 SHA512 29b58afba1c0b473205cf7070997139d2ca07cf68d40185aa76fa59c900ad21c03ccb79dec9970e5f96743cfdb5a7d926b21a9947244bc8cf8cbd1033467cd01
DIST gtksourceview-4.0.3.tar.xz 1396640 BLAKE2B 5e5f84597c1f75a732ac487c2107eb54be2740eb2cabd177aec76cb4b2504a32969c4918e2a1294e9d486660090985a4f588dbde49f241fbb1493eaa3daa335b SHA512 d3f7512bddf247166c12dc38bc66d55e44c1830f9b8d62758f06cb7117e33f8908f4d8186b9d7e77514623a58f3a973cc75e3fd6a09c5f891f8b948012a76955
+DIST gtksourceview-4.2.0.tar.xz 1410764 BLAKE2B 8f20a762c16a0abc47ff191a2ea4d6b44a397cabee056e98263d0ba59cbc7207ac72341a630aa83fe7855804bd6add77e0d93e706ac9561c9577843f17e00246 SHA512 f2350b1e7042309c01be0feda6059d788a7ef55c4ccd48e16b4c92a71292ed6f92243455ca42aa0950db61de8d68f4a76f4fac46cd46316b690bcef1ea34c641
diff --git a/x11-libs/gtksourceview/gtksourceview-4.2.0.ebuild b/x11-libs/gtksourceview/gtksourceview-4.2.0.ebuild
new file mode 100644
index 000000000000..d3bac6fc419c
--- /dev/null
+++ b/x11-libs/gtksourceview/gtksourceview-4.2.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+VALA_MIN_API_VERSION="0.24"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala virtualx
+
+DESCRIPTION="A text widget implementing syntax highlighting and other features"
+HOMEPAGE="https://wiki.gnome.org/Projects/GtkSourceView"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="4"
+
+IUSE="glade +introspection +vala"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+
+RDEPEND="
+ >=dev-libs/glib-2.48:2
+ >=dev-libs/libxml2-2.6:2
+ >=x11-libs/gtk+-3.20:3[introspection?]
+ glade? ( >=dev-util/glade-3.9:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-1.42:= )
+"
+DEPEND="${RDEPEND}
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.25
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable glade glade-catalog) \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}
+
+src_test() {
+ virtx emake check
+}
+
+src_install() {
+ gnome2_src_install
+
+ insinto /usr/share/${PN}-4/language-specs
+ doins "${FILESDIR}"/2.0/gentoo.lang
+
+ # Avoid conflict with gtksourceview:3.0 glade-catalog
+ # TODO: glade doesn't actually show multiple GtkSourceView widget collections, so with both installed, can't really be sure which ones are used
+ if use glade; then
+ mv "${ED}"/usr/share/glade/catalogs/gtksourceview.xml "${ED}"/usr/share/glade/catalogs/gtksourceview-${SLOT}.xml || die
+ fi
+}