summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-04-20 08:16:48 -0500
committerAnthony G. Basile <blueness@gentoo.org>2018-04-24 05:19:50 -0400
commit586b79141ea7ae54e65950874ab08198a15814b4 (patch)
treec11c114b9e7f4f103f9abd4d96480106918e2e01
parentsys-devel/gdb: add explicit epatch (diff)
downloadgentoo-586b79141ea7ae54e65950874ab08198a15814b4.tar.gz
gentoo-586b79141ea7ae54e65950874ab08198a15814b4.tar.bz2
gentoo-586b79141ea7ae54e65950874ab08198a15814b4.zip
sys-devel/gdb: explicit epatch, git-2->git-r3, EAPI=6
Also some formatting changes to keep the ebuilds aligned in layout. Package-Manager: Portage-2.3.31, Repoman-2.3.9 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
-rw-r--r--sys-devel/gdb/gdb-8.0.1-r1.ebuild2
-rw-r--r--sys-devel/gdb/gdb-8.0.1.ebuild2
-rw-r--r--sys-devel/gdb/gdb-8.0.ebuild2
-rw-r--r--sys-devel/gdb/gdb-8.1-r1.ebuild2
-rw-r--r--sys-devel/gdb/gdb-8.1.ebuild2
-rw-r--r--sys-devel/gdb/gdb-9999.ebuild18
6 files changed, 17 insertions, 11 deletions
diff --git a/sys-devel/gdb/gdb-8.0.1-r1.ebuild b/sys-devel/gdb/gdb-8.0.1-r1.ebuild
index f2de213b735c..a03b93441024 100644
--- a/sys-devel/gdb/gdb-8.0.1-r1.ebuild
+++ b/sys-devel/gdb/gdb-8.0.1-r1.ebuild
@@ -20,7 +20,7 @@ case ${PV} in
9999*)
# live git tree
EGIT_REPO_URI="git://sourceware.org/git/binutils-gdb.git"
- inherit git-2
+ inherit git-r3
SRC_URI=""
;;
*.*.50.2???????)
diff --git a/sys-devel/gdb/gdb-8.0.1.ebuild b/sys-devel/gdb/gdb-8.0.1.ebuild
index c961c9df536d..84138d2c9341 100644
--- a/sys-devel/gdb/gdb-8.0.1.ebuild
+++ b/sys-devel/gdb/gdb-8.0.1.ebuild
@@ -20,7 +20,7 @@ case ${PV} in
9999*)
# live git tree
EGIT_REPO_URI="git://sourceware.org/git/binutils-gdb.git"
- inherit git-2
+ inherit git-r3
SRC_URI=""
;;
*.*.50.2???????)
diff --git a/sys-devel/gdb/gdb-8.0.ebuild b/sys-devel/gdb/gdb-8.0.ebuild
index 5ceaef605501..447d9073015f 100644
--- a/sys-devel/gdb/gdb-8.0.ebuild
+++ b/sys-devel/gdb/gdb-8.0.ebuild
@@ -20,7 +20,7 @@ case ${PV} in
9999*)
# live git tree
EGIT_REPO_URI="git://sourceware.org/git/binutils-gdb.git"
- inherit git-2
+ inherit git-r3
SRC_URI=""
;;
*.*.50.2???????)
diff --git a/sys-devel/gdb/gdb-8.1-r1.ebuild b/sys-devel/gdb/gdb-8.1-r1.ebuild
index cd11a56608a9..6c7a856e418a 100644
--- a/sys-devel/gdb/gdb-8.1-r1.ebuild
+++ b/sys-devel/gdb/gdb-8.1-r1.ebuild
@@ -20,7 +20,7 @@ case ${PV} in
9999*)
# live git tree
EGIT_REPO_URI="git://sourceware.org/git/binutils-gdb.git"
- inherit git-2
+ inherit git-r3
SRC_URI=""
;;
*.*.50.2???????)
diff --git a/sys-devel/gdb/gdb-8.1.ebuild b/sys-devel/gdb/gdb-8.1.ebuild
index cd11a56608a9..6c7a856e418a 100644
--- a/sys-devel/gdb/gdb-8.1.ebuild
+++ b/sys-devel/gdb/gdb-8.1.ebuild
@@ -20,7 +20,7 @@ case ${PV} in
9999*)
# live git tree
EGIT_REPO_URI="git://sourceware.org/git/binutils-gdb.git"
- inherit git-2
+ inherit git-r3
SRC_URI=""
;;
*.*.50.2???????)
diff --git a/sys-devel/gdb/gdb-9999.ebuild b/sys-devel/gdb/gdb-9999.ebuild
index 553005830a8d..690244835479 100644
--- a/sys-devel/gdb/gdb-9999.ebuild
+++ b/sys-devel/gdb/gdb-9999.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-inherit flag-o-matic eutils python-single-r1
+inherit epatch eutils flag-o-matic python-single-r1
export CTARGET=${CTARGET:-${CHOST}}
if [[ ${CTARGET} == ${CHOST} ]] ; then
@@ -20,7 +20,7 @@ case ${PV} in
9999*)
# live git tree
EGIT_REPO_URI="git://sourceware.org/git/binutils-gdb.git"
- inherit git-2
+ inherit git-r3
SRC_URI=""
;;
*.*.50.2???????)
@@ -49,9 +49,13 @@ case ${PV} in
esac
PATCH_VER=""
+PATCH_DEV=""
DESCRIPTION="GNU debugger"
HOMEPAGE="https://sourceware.org/gdb/"
-SRC_URI="${SRC_URI} ${PATCH_VER:+mirror://gentoo/${P}-patches-${PATCH_VER}.tar.xz}"
+SRC_URI="${SRC_URI}
+ ${PATCH_DEV:+https://dev.gentoo.org/~${PATCH_DEV}/distfiles/${P}-patches-${PATCH_VER}.tar.xz}
+ ${PATCH_VER:+mirror://gentoo/${P}-patches-${PATCH_VER}.tar.xz}
+"
LICENSE="GPL-2 LGPL-2"
SLOT="0"
@@ -91,7 +95,9 @@ pkg_setup() {
src_prepare() {
[[ -n ${RPM} ]] && rpm_spec_epatch "${WORKDIR}"/gdb.spec
! use vanilla && [[ -n ${PATCH_VER} ]] && EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/patch
- epatch_user
+
+ default
+
strip-linguas -u bfd/po opcodes/po
}