summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-07-12 23:42:43 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-07-13 22:54:38 +0200
commitc2ffda46048a4123d62f8802548cd5a5840c5001 (patch)
tree4b75dcab0fca1454f8e54b455f0552338a531cea
parentnet-analyzer/scanlogd: migrate to GLEP 81 (diff)
downloadgentoo-c2ffda46048a4123d62f8802548cd5a5840c5001.tar.gz
gentoo-c2ffda46048a4123d62f8802548cd5a5840c5001.tar.bz2
gentoo-c2ffda46048a4123d62f8802548cd5a5840c5001.zip
net-analyzer/scanlogd: drop old version
Bug: https://bugs.gentoo.org/781356 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--net-analyzer/scanlogd/scanlogd-2.2.7.ebuild51
-rw-r--r--net-analyzer/scanlogd/scanlogd-2.2.8.ebuild56
2 files changed, 0 insertions, 107 deletions
diff --git a/net-analyzer/scanlogd/scanlogd-2.2.7.ebuild b/net-analyzer/scanlogd/scanlogd-2.2.7.ebuild
deleted file mode 100644
index 7fb4b5b2a9d4..000000000000
--- a/net-analyzer/scanlogd/scanlogd-2.2.7.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit savedconfig toolchain-funcs user
-
-DESCRIPTION="A port scan detection tool"
-SRC_URI="http://www.openwall.com/scanlogd/${P}.tar.gz"
-HOMEPAGE="http://www.openwall.com/scanlogd/"
-
-LICENSE="scanlogd GPL-2" # GPL-2 for initscript
-SLOT="0"
-KEYWORDS="~amd64 ppc x86"
-IUSE="+nids pcap"
-REQUIRED_USE="?? ( nids pcap )"
-
-DEPEND="
- nids? ( net-libs/libnids )
- pcap? ( net-libs/libpcap )
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-gentoo.patch
-)
-
-src_prepare() {
- default
- restore_config params.h
- tc-export CC
-}
-
-src_compile() {
- local target=linux
- use nids && target=libnids
- use pcap && target=libpcap
- emake ${target}
-}
-
-src_install() {
- dosbin scanlogd
- doman scanlogd.8
- newinitd "${FILESDIR}"/scanlogd.rc scanlogd
- save_config params.h
-}
-
-pkg_preinst() {
- enewgroup scanlogd
- enewuser scanlogd -1 -1 /dev/null scanlogd
-}
diff --git a/net-analyzer/scanlogd/scanlogd-2.2.8.ebuild b/net-analyzer/scanlogd/scanlogd-2.2.8.ebuild
deleted file mode 100644
index c21dc3ec5c8f..000000000000
--- a/net-analyzer/scanlogd/scanlogd-2.2.8.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit savedconfig toolchain-funcs user
-
-DESCRIPTION="A port scan detection tool"
-SRC_URI="https://www.openwall.com/scanlogd/${P}.tar.gz"
-HOMEPAGE="https://www.openwall.com/scanlogd/"
-
-LICENSE="scanlogd GPL-2" # GPL-2 for initscript
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="+nids pcap"
-REQUIRED_USE="?? ( nids pcap )"
-
-DEPEND="
- nids? ( net-libs/libnids )
- pcap? ( net-libs/libpcap )
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.2.7-gentoo.patch
-)
-
-src_prepare() {
- default
-
- restore_config params.h
-
- tc-export CC
-}
-
-src_compile() {
- local target=linux
-
- use nids && target=libnids
- use pcap && target=libpcap
- emake ${target}
-}
-
-src_install() {
- dosbin scanlogd
-
- doman scanlogd.8
- newinitd "${FILESDIR}"/scanlogd.rc scanlogd
-
- save_config params.h
-}
-
-pkg_preinst() {
- enewgroup scanlogd
- enewuser scanlogd -1 -1 /dev/null scanlogd
-}