summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2023-01-22 20:19:02 -0600
committerMatthias Maier <tamiko@gentoo.org>2023-01-22 20:19:02 -0600
commit1fee59e8f357d681721edd0ce4e7b9896ee7ab83 (patch)
tree2700e2b13c0ec593b748844ec8e505b893edb15e /dev-cpp/muParser
parentdev-cpp/muParser: Remove USE=wchar (diff)
downloadgentoo-1fee59e8f357d681721edd0ce4e7b9896ee7ab83.tar.gz
gentoo-1fee59e8f357d681721edd0ce4e7b9896ee7ab83.tar.bz2
gentoo-1fee59e8f357d681721edd0ce4e7b9896ee7ab83.zip
dev-cpp/muParser: add missing openmp check
Closes: https://bugs.gentoo.org/875257 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'dev-cpp/muParser')
-rw-r--r--dev-cpp/muParser/muParser-2.3.3-r2.ebuild10
-rw-r--r--dev-cpp/muParser/muParser-2.3.4-r1.ebuild10
2 files changed, 18 insertions, 2 deletions
diff --git a/dev-cpp/muParser/muParser-2.3.3-r2.ebuild b/dev-cpp/muParser/muParser-2.3.3-r2.ebuild
index cab8c4f6caf3..cc9e5ae7de10 100644
--- a/dev-cpp/muParser/muParser-2.3.3-r2.ebuild
+++ b/dev-cpp/muParser/muParser-2.3.3-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake
+inherit cmake toolchain-funcs
# The upstream tag is v2.3.3-1 instead of v2.3.3
suffix="-1"
@@ -21,6 +21,14 @@ RESTRICT="!test? ( test )"
S="${S}${suffix}"
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
src_configure() {
local mycmakeargs=(
-DENABLE_OPENMP=$(usex openmp)
diff --git a/dev-cpp/muParser/muParser-2.3.4-r1.ebuild b/dev-cpp/muParser/muParser-2.3.4-r1.ebuild
index 363cf05aaf0d..910218afa123 100644
--- a/dev-cpp/muParser/muParser-2.3.4-r1.ebuild
+++ b/dev-cpp/muParser/muParser-2.3.4-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake
+inherit cmake toolchain-funcs
DESCRIPTION="Library for parsing mathematical expressions"
HOMEPAGE="https://beltoforion.de/en/muparser/"
@@ -16,6 +16,14 @@ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-li
IUSE="doc openmp test"
RESTRICT="!test? ( test )"
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
src_configure() {
local mycmakeargs=(
-DENABLE_OPENMP=$(usex openmp)