summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2019-04-17 21:16:28 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2019-04-17 22:10:33 -0700
commit49f18ba9825592e2425b6e793a706c73d41599c7 (patch)
tree13567da369c0ebc76f35a6d373eefad75b1b303d /dev-db
parentdev-db/redis: bump to 5.0.4 (diff)
downloadgentoo-49f18ba9825592e2425b6e793a706c73d41599c7.tar.gz
gentoo-49f18ba9825592e2425b6e793a706c73d41599c7.tar.bz2
gentoo-49f18ba9825592e2425b6e793a706c73d41599c7.zip
dev-db/redis: fix Tcl BDEPEND req
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Fixes: http://github.com/gentoo/gentoo/pull/11456#discussion_r268048208 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/redis/redis-4.0.14.ebuild9
-rw-r--r--dev-db/redis/redis-5.0.4.ebuild9
2 files changed, 10 insertions, 8 deletions
diff --git a/dev-db/redis/redis-4.0.14.ebuild b/dev-db/redis/redis-4.0.14.ebuild
index 1f0ac4ef03da..5f2c18f61cbc 100644
--- a/dev-db/redis/redis-4.0.14.ebuild
+++ b/dev-db/redis/redis-4.0.14.ebuild
@@ -23,13 +23,14 @@ RDEPEND="
tcmalloc? ( dev-util/google-perftools )
jemalloc? ( >=dev-libs/jemalloc-3.2 )"
-DEPEND="
- ${RDEPEND}
- test? ( dev-lang/tcl:0= )"
-
BDEPEND="
+ ${RDEPEND}
virtual/pkgconfig"
+# Tcl is only needed in the CHOST test env
+DEPEND="${RDEPEND}
+ test? ( dev-lang/tcl:0= )"
+
REQUIRED_USE="?? ( tcmalloc jemalloc )"
pkg_setup() {
diff --git a/dev-db/redis/redis-5.0.4.ebuild b/dev-db/redis/redis-5.0.4.ebuild
index ec8944b4940a..519fc3837ca9 100644
--- a/dev-db/redis/redis-5.0.4.ebuild
+++ b/dev-db/redis/redis-5.0.4.ebuild
@@ -23,13 +23,14 @@ RDEPEND="
tcmalloc? ( dev-util/google-perftools )
jemalloc? ( >=dev-libs/jemalloc-5.1:= )"
-DEPEND="
- ${RDEPEND}
- test? ( dev-lang/tcl:0= )"
-
BDEPEND="
+ ${RDEPEND}
virtual/pkgconfig"
+# Tcl is only needed in the CHOST test env
+DEPEND="${RDEPEND}
+ test? ( dev-lang/tcl:0= )"
+
REQUIRED_USE="?? ( tcmalloc jemalloc )"
pkg_setup() {