summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-28 10:15:26 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-28 10:15:26 +0100
commitc25f19f2cb73a6a0dd54380efcc90baa291bf034 (patch)
tree6193958439d289459b8db91772cfd47a1037ff8f /dev-python/PyContracts
parentdev-python/coverage: Version Bump (diff)
downloadgentoo-c25f19f2cb73a6a0dd54380efcc90baa291bf034.tar.gz
gentoo-c25f19f2cb73a6a0dd54380efcc90baa291bf034.tar.bz2
gentoo-c25f19f2cb73a6a0dd54380efcc90baa291bf034.zip
dev-python/PyContracts: Version Bump
Package-Manager: portage-2.2.25 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/PyContracts')
-rw-r--r--dev-python/PyContracts/Manifest1
-rw-r--r--dev-python/PyContracts/PyContracts-1.7.9.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/PyContracts/Manifest b/dev-python/PyContracts/Manifest
index 8a008adf64ab..7c8762e62cb4 100644
--- a/dev-python/PyContracts/Manifest
+++ b/dev-python/PyContracts/Manifest
@@ -1 +1,2 @@
DIST PyContracts-1.7.6.tar.gz 58711 SHA256 94814b376b168483edeee33fdf1a04d892065d0bdfe0638d281c285d1f3e42bf SHA512 6c76e9f04e3553b2212749bb135351860d8a6e35e13f4a35f65bf7acfa14e031fec005b1f462f9948162cfcd60f4dce7d11d7fa30cb800ce199a0bf4f3b1c472 WHIRLPOOL 52da995c03bc1cb0c2dbdeaa00cbcb35e621b69a16ee0f5630207a62cca0a058d26d90acde4db6c22e785e60f9f4387caf935fac2af2e8e305d016e52a77f507
+DIST PyContracts-1.7.9.tar.gz 61033 SHA256 0ebb8c434700d1a990bd4f53dbbf1caec297b3a783c9af26de052104fe4dac65 SHA512 1db6491d4be3df96753dcdd6f85329d47409a2424177a52d1e35f5a1d58f671290d22d807b70f632f0376c86c58c093118f7223b7ad59893a85dccdb91d29f50 WHIRLPOOL 520a0836e1f65e389e1c09f74e52ddf2ab42c315de25cda34cb31332de245309fd38649fd30a6ee737a6e3ec189d3241340747ed111e3b84b92325bc5d22a9cf
diff --git a/dev-python/PyContracts/PyContracts-1.7.9.ebuild b/dev-python/PyContracts/PyContracts-1.7.9.ebuild
new file mode 100644
index 000000000000..a0aefee7bf4f
--- /dev/null
+++ b/dev-python/PyContracts/PyContracts-1.7.9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Declare constraints on function parameters and return values"
+HOMEPAGE="http://andreacensi.github.com/contracts/ https://pypi.python.org/pypi/PyContracts/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+# Upstream allows tests to fail
+RESTRICT=test
+
+python_test() {
+ nosetests \
+ $(python_is_python3 || echo "--ignore-files=test_py3k_annotations.py") \
+ || die
+}