summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/envoy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/envoy')
-rw-r--r--dev-python/envoy/Manifest1
-rw-r--r--dev-python/envoy/envoy-0.0.3.ebuild25
-rw-r--r--dev-python/envoy/files/test_envoy.py52
-rw-r--r--dev-python/envoy/metadata.xml9
4 files changed, 87 insertions, 0 deletions
diff --git a/dev-python/envoy/Manifest b/dev-python/envoy/Manifest
new file mode 100644
index 000000000000..867df2629364
--- /dev/null
+++ b/dev-python/envoy/Manifest
@@ -0,0 +1 @@
+DIST envoy-0.0.3.tar.gz 4190 SHA256 22b02009cfda2cf2cdb94a75a15ac3fd910aea8685c53e8e03715c7e9d8e8bde SHA512 3af97b95d61f12ef0d8dc71234023a69123667ef26feec9342bda4c3307629728be589be3ac7d118f6cf17aeb6b5ee91c23f37f84c411f117f5e76a5b024a967 WHIRLPOOL fca1eb6de99d90c8c94598bf5524f8ff5e41ab96f5b351e8bcd20cfc729fc8a4f360d744d25f5af4d80dd6b5ad3624a5fb041041268c4ebcf7d5154ccf62db56
diff --git a/dev-python/envoy/envoy-0.0.3.ebuild b/dev-python/envoy/envoy-0.0.3.ebuild
new file mode 100644
index 000000000000..0347ba0f991b
--- /dev/null
+++ b/dev-python/envoy/envoy-0.0.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple API for running external processes"
+HOMEPAGE="https://github.com/kennethreitz/envoy http://pypi.python.org/pypi/envoy"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_test() {
+ # and it fails almost all;https://github.com/kennethreitz/envoy/issues/58
+ "${PYTHON}" test_envoy.py
+}
diff --git a/dev-python/envoy/files/test_envoy.py b/dev-python/envoy/files/test_envoy.py
new file mode 100644
index 000000000000..8c83a0816a27
--- /dev/null
+++ b/dev-python/envoy/files/test_envoy.py
@@ -0,0 +1,52 @@
+import unittest
+import envoy
+import time
+
+class SimpleTest(unittest.TestCase):
+
+ def test_input(self):
+ r = envoy.run("sed s/i/I/g", "Hi")
+ self.assertEqual(r.std_out.rstrip(), "HI")
+ self.assertEqual(r.status_code, 0)
+
+ def test_pipe(self):
+ r = envoy.run("echo -n 'hi'| tr [:lower:] [:upper:]")
+ self.assertEqual(r.std_out, "HI")
+ self.assertEqual(r.status_code, 0)
+
+ def test_timeout(self):
+ r = envoy.run('yes | head', timeout=1)
+ self.assertEqual(r.std_out, 'y\ny\ny\ny\ny\ny\ny\ny\ny\ny\n')
+ self.assertEqual(r.status_code, 0)
+
+ # THIS TEST FAILS BECAUSE expand_args DOESN'T HANDLE QUOTES PROPERLY
+ def test_quoted_args(self):
+ sentinel = 'quoted_args' * 3
+ r = envoy.run("python -c 'print \"%s\"'" % sentinel)
+ self.assertEqual(r.std_out.rstrip(), sentinel)
+ self.assertEqual(r.status_code, 0)
+
+class ConnectedCommandTests(unittest.TestCase):
+
+ def test_status_code_none(self):
+ c = envoy.connect("sleep 5")
+ self.assertEqual(c.status_code, None)
+
+ def test_status_code_success(self):
+ c = envoy.connect("sleep 1")
+ time.sleep(2)
+ self.assertEqual(c.status_code, 0)
+
+ def test_status_code_failure(self):
+ c = envoy.connect("sleeep 1")
+ self.assertEqual(c.status_code, 127)
+
+ def test_input(self):
+ test_string = 'asdfQWER'
+ r = envoy.connect("cat | tr [:lower:] [:upper:]")
+ r.send(test_string)
+ self.assertEqual(r.std_out, test_string.upper())
+ self.assertEqual(r.status_code, 0)
+
+if __name__ == "__main__":
+ unittest.main()
diff --git a/dev-python/envoy/metadata.xml b/dev-python/envoy/metadata.xml
new file mode 100644
index 000000000000..5b4829404b83
--- /dev/null
+++ b/dev-python/envoy/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">envoy</remote-id>
+ <remote-id type="github">kennethreitz/envoy</remote-id>
+ </upstream>
+</pkgmetadata>