summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/parassign
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/parassign')
-rw-r--r--sci-chemistry/parassign/Manifest1
-rw-r--r--sci-chemistry/parassign/metadata.xml27
-rw-r--r--sci-chemistry/parassign/parassign-20130522.ebuild65
3 files changed, 93 insertions, 0 deletions
diff --git a/sci-chemistry/parassign/Manifest b/sci-chemistry/parassign/Manifest
new file mode 100644
index 000000000000..d4edb48300ce
--- /dev/null
+++ b/sci-chemistry/parassign/Manifest
@@ -0,0 +1 @@
+DIST PARAssign_Linux_x64_86.tgz 76693208 SHA256 56a322a8825c13cd3e7d90998471c47fb6062e79e2d20108b4fb6ed24664c89d SHA512 63018b0f1e3ce7821cebb90cd59ef5fdfa44b7ce6776956184b55a6247009f5e9df435332772dfa0db7294308c4d930ff0104daf45a46df709fb132dac10bd79 WHIRLPOOL 87ae85974f2a84c3814d261390e011f7ef2a012881df15f0f8ba4a7b5e88992e7932f12566847eaa38958394f7a243a4f0d536375e4640377d6f183e793bccc5
diff --git a/sci-chemistry/parassign/metadata.xml b/sci-chemistry/parassign/metadata.xml
new file mode 100644
index 000000000000..144ad6d646ca
--- /dev/null
+++ b/sci-chemistry/parassign/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+The use of paramagnetic NMR data for the refinement of structures of proteins
+and protein complexes is widespread. However, the power of paramagnetism for
+protein assignment has not yet been fully exploited. PARAssign is software that
+uses pseudocontact shift data derived from several paramagnetic centers attached
+to the protein to obtain amide and methyl assignments. The ability of PARAssign
+to perform assignment when the positions of the paramagnetic centers are known
+and unknown is demonstrated. PARAssign has been tested using synthetic data for
+methyl assignment of a 47 kDa protein, and using both synthetic and experimental
+data for amide assignment of a 14 kDa protein. The complex fitting space
+involved in such an assignment procedure necessitates that good starting
+conditions are found, both regarding placement and strength of paramagnetic
+centers. These starting conditions are obtained through automated tensor
+placement and user-defined tensor parameters. The results presented herein
+demonstrate that PARAssign is able to successfully perform resonance assignment
+in large systems with a high degree of reliability. This software provides a
+method for obtaining the assignments of large systems, which may previously have
+been unassignable, by using 2D NMR spectral data and a known protein structure.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-chemistry/parassign/parassign-20130522.ebuild b/sci-chemistry/parassign/parassign-20130522.ebuild
new file mode 100644
index 000000000000..8ecbd0060d10
--- /dev/null
+++ b/sci-chemistry/parassign/parassign-20130522.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 python-r1
+
+DESCRIPTION="Assign protein nuclei solely on the basis of pseudocontact shifts (PCS)"
+HOMEPAGE="http://protchem.lic.leidenuniv.nl/software/parassign/registration"
+SRC_URI="PARAssign_Linux_x64_86.tgz"
+RESTRICT="fetch"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/scientificpython[${PYTHON_USEDEP}]
+ sci-biology/biopython[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}"/PARAssign_Linux_x64_86/
+
+src_prepare() {
+ sed \
+ -e '1i#!/usr/bin/python2' \
+ -i code/*py || die
+
+ if use x86; then
+ sed \
+ -e "s:munkres64:munkres:g" \
+ -i modules/setup.py || die
+ elif use amd64; then
+ sed \
+ -e "s:munkres:munkres64:g" \
+ -i code/*py || die
+ fi
+ cd modules || die
+ rm *o *c || die
+ distutils-r1_src_prepare
+}
+
+src_compile() {
+ cd modules || die
+ distutils-r1_src_compile
+}
+
+src_install() {
+ python_parallel_foreach_impl python_doscript code/* || die
+
+ dodoc PARAssign_Tutorial.pdf README
+
+ cd modules || die
+ distutils-r1_src_install
+}