summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-07-28 12:36:32 +0200
committerJeroen Roovers <jer@gentoo.org>2018-07-28 12:36:56 +0200
commitd8b32c9cba5850d0d84a11c46923800d9f47b7e7 (patch)
tree0b0a6df73fa61cf991cbafddc30a526b6f6f0786 /x11-terms/guake
parentx11-terms/guake: Version 3.3.2. (diff)
downloadgentoo-d8b32c9cba5850d0d84a11c46923800d9f47b7e7.tar.gz
gentoo-d8b32c9cba5850d0d84a11c46923800d9f47b7e7.tar.bz2
gentoo-d8b32c9cba5850d0d84a11c46923800d9f47b7e7.zip
x11-terms/guake: Update live ebuild.
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'x11-terms/guake')
-rw-r--r--x11-terms/guake/guake-9999.ebuild64
1 files changed, 32 insertions, 32 deletions
diff --git a/x11-terms/guake/guake-9999.ebuild b/x11-terms/guake/guake-9999.ebuild
index 5f3f7f992452..46f3706e7f3d 100644
--- a/x11-terms/guake/guake-9999.ebuild
+++ b/x11-terms/guake/guake-9999.ebuild
@@ -1,60 +1,60 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+PYTHON_COMPAT=( python3_{5,6} )
+DISTUTILS_SINGLE_IMPL=1
-GNOME2_LA_PUNT=yes
-PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1 git-r3 gnome2-utils xdg-utils
-inherit autotools git-r3 gnome2 python-single-r1
-
-DESCRIPTION="Drop-down terminal for GTK+ desktops"
-HOMEPAGE="https://github.com/Guake/guake"
-# override gnome.org.eclass SRC_URI
-SRC_URI=''
+DESCRIPTION="Drop-down terminal for GNOME"
+HOMEPAGE="https://github.com/Guake/guake https://pypi.org/project/Guake"
EGIT_REPO_URI="https://github.com/Guake/guake.git"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+IUSE="utempter"
RDEPEND="
- ${PYTHON_DEPS}
+ dev-libs/keybinder:3
dev-python/dbus-python[${PYTHON_USEDEP}]
- dev-python/gconf-python[${PYTHON_USEDEP}]
- dev-python/notify-python[${PYTHON_USEDEP}]
- dev-python/pygtk[${PYTHON_USEDEP}]
- dev-python/pyxdg[${PYTHON_USEDEP}]
- x11-libs/gtk+:2
- x11-libs/libX11
- x11-libs/vte:0[python]
+ dev-python/pbr[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/libnotify
+ x11-libs/vte:2.91
+ utempter? ( sys-libs/libutempter )
"
DEPEND="
${RDEPEND}
- dev-util/intltool
- virtual/pkgconfig
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ gnome-base/gsettings-desktop-schemas
+ sys-devel/gettext
+ sys-devel/make
"
-DOCS=( AUTHORS ChangeLog NEWS README.rst )
-
-src_unpack() {
- # override gnome2_src_unpack()
- git-r3_src_unpack
-}
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.3.2-paths.patch
+)
-src_prepare() {
+python_compile_all() {
+ emake prepare-install prefix=/usr
+ emake generate-paths prefix=/usr DATA_DIR='$(datadir)/guake' DEV_SCHEMA_DIR='$(gsettingsschemadir)'
default
+}
- eautoreconf
-
- gnome2_src_prepare
+python_install_all() {
+ emake install-schemas install-locale prefix=/usr DESTDIR="${D}"
+ distutils-r1_python_install_all
}
pkg_postinst() {
- gnome2_pkg_postinst
+ gnome2_schemas_update
+ xdg_desktop_database_update
}
pkg_postrm() {
- gnome2_pkg_postrm
+ gnome2_schemas_update
+ xdg_desktop_database_update
}