summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-visualization/xyscan/xyscan-3.3.1.ebuild')
-rw-r--r--sci-visualization/xyscan/xyscan-3.3.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sci-visualization/xyscan/xyscan-3.3.1.ebuild b/sci-visualization/xyscan/xyscan-3.3.1.ebuild
new file mode 100644
index 000000000000..a4adade1518a
--- /dev/null
+++ b/sci-visualization/xyscan/xyscan-3.3.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+LANGS="fr"
+
+inherit eutils qt4-r2 versionator
+
+MY_PV=$(replace_version_separator 2 '')
+
+DESCRIPTION="Tool for extracting data points from graphs"
+HOMEPAGE="http://star.physics.yale.edu/~ullrich/xyscanDistributionPage/"
+SRC_URI="http://star.physics.yale.edu/~ullrich/${PN}DistributionPage/${MY_PV}/${PN}-${MY_PV}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-qt/qtcore:4
+ dev-qt/qtgui:4"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ sed -i \
+ -e "s:qApp->applicationDirPath() + \"/../docs\":\"${EPREFIX}/usr/share/doc/${PF}/html\":" \
+ xyscanWindow.cpp || die "Failed to fix docs path"
+}
+
+src_install() {
+ dobin xyscan
+ dohtml -r docs/en/*
+ use linguas_fr && doins -r docs/fr
+ newicon images/xyscanIcon.png xyscan.png
+ make_desktop_entry xyscan "xyscan data point extractor"
+}