summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-visualization/xyscan')
-rw-r--r--sci-visualization/xyscan/Manifest1
-rw-r--r--sci-visualization/xyscan/metadata.xml11
-rw-r--r--sci-visualization/xyscan/xyscan-3.3.1.ebuild39
3 files changed, 51 insertions, 0 deletions
diff --git a/sci-visualization/xyscan/Manifest b/sci-visualization/xyscan/Manifest
new file mode 100644
index 000000000000..bf58755f2472
--- /dev/null
+++ b/sci-visualization/xyscan/Manifest
@@ -0,0 +1 @@
+DIST xyscan-3.31-src.tar.gz 1122203 SHA256 6cfecaf801453fbc20f358ee39370aad950c80769933e5b451e0a5cc927a928d SHA512 418456348d2493cc365c4cae4760a246d8113e1b0cf74c03aa385a5a40b02c20fdb873c007afea7e244e493c52eb2803cee4da0338f6e090ef87f20dc9a50f42 WHIRLPOOL 29a7650fba5270c2106944de2b6bc1200a44e8d92d9dcebe855951310a7eacafe721e529c0801f80317c12a1714782bada04fd1da6d365ebc86d2e83cbce98dc
diff --git a/sci-visualization/xyscan/metadata.xml b/sci-visualization/xyscan/metadata.xml
new file mode 100644
index 000000000000..627b48457810
--- /dev/null
+++ b/sci-visualization/xyscan/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ xyscan is a tool for scientist in the need to extract data points,
+ i.e. numeric values, from a plot. It allows to scan the plots and
+ extract data points including the size of the error bars (both in x
+ and y). It can handle plots with linear and logarithmic scales.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-visualization/xyscan/xyscan-3.3.1.ebuild b/sci-visualization/xyscan/xyscan-3.3.1.ebuild
new file mode 100644
index 000000000000..a4adade1518a
--- /dev/null
+++ b/sci-visualization/xyscan/xyscan-3.3.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+LANGS="fr"
+
+inherit eutils qt4-r2 versionator
+
+MY_PV=$(replace_version_separator 2 '')
+
+DESCRIPTION="Tool for extracting data points from graphs"
+HOMEPAGE="http://star.physics.yale.edu/~ullrich/xyscanDistributionPage/"
+SRC_URI="http://star.physics.yale.edu/~ullrich/${PN}DistributionPage/${MY_PV}/${PN}-${MY_PV}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-qt/qtcore:4
+ dev-qt/qtgui:4"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ sed -i \
+ -e "s:qApp->applicationDirPath() + \"/../docs\":\"${EPREFIX}/usr/share/doc/${PF}/html\":" \
+ xyscanWindow.cpp || die "Failed to fix docs path"
+}
+
+src_install() {
+ dobin xyscan
+ dohtml -r docs/en/*
+ use linguas_fr && doins -r docs/fr
+ newicon images/xyscanIcon.png xyscan.png
+ make_desktop_entry xyscan "xyscan data point extractor"
+}