aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Leise <marco.leise@gmx.de>2020-01-07 00:09:22 +0100
committerMarco Leise <marco.leise@gmx.de>2020-01-07 00:09:22 +0100
commita7b16074e2ed270bc40a2c944b8cbae715a21da4 (patch)
tree029583f088a7590133f82613c7255ec37c055b9d
parentonedrive-2.3.13 (diff)
downloaddlang-a7b16074e2ed270bc40a2c944b8cbae715a21da4.tar.gz
dlang-a7b16074e2ed270bc40a2c944b8cbae715a21da4.tar.bz2
dlang-a7b16074e2ed270bc40a2c944b8cbae715a21da4.zip
dmd-2.090.0 & dub-1.19
Signed-off-by: Marco Leise <marco.leise@gmx.de>
-rw-r--r--dev-lang/dmd/Manifest1
-rw-r--r--dev-lang/dmd/dmd-2.088.1-r1.ebuild5
-rw-r--r--dev-lang/dmd/dmd-2.089.0-r1.ebuild5
-rw-r--r--dev-lang/dmd/dmd-2.089.1.ebuild5
-rw-r--r--dev-lang/dmd/dmd-2.090.0.ebuild20
-rw-r--r--dev-util/dlang-tools/Manifest1
-rw-r--r--dev-util/dlang-tools/dlang-tools-2.090.0.ebuild54
-rw-r--r--dev-util/dub/Manifest1
-rw-r--r--dev-util/dub/dub-1.19.0.ebuild39
-rw-r--r--dev-util/dub/files/dub-1.19.0-gdc-dmd-pathfix.patch16
-rw-r--r--eclass/dmd.eclass2
11 files changed, 136 insertions, 13 deletions
diff --git a/dev-lang/dmd/Manifest b/dev-lang/dmd/Manifest
index 9539a50..20ecedb 100644
--- a/dev-lang/dmd/Manifest
+++ b/dev-lang/dmd/Manifest
@@ -26,3 +26,4 @@ DIST dmd.2.087.1.linux.tar.xz 25120264 BLAKE2B fb6aed0ebf1547565f99717830acfe450
DIST dmd.2.088.1.linux.tar.xz 25122116 BLAKE2B e573a97cf9f547a3017a0b904523f4877782bef98144744f064a539e87fac8c0938b2963308a0e4046b934a700273338cbea32467b472daf665c9c5673ee5e06 SHA512 e98183870cab35b67967b73149a10025b257ba9ce9aafabdbdd1d91cc3009b90d13d0b5173fb5e32d53da890de7b7bd41deddec19774baaafa84c6efef4717a8
DIST dmd.2.089.0.linux.tar.xz 25693688 BLAKE2B 034d90b18e32d382d3e9c78654560b20cfc89f53cf4395b46c2b0f09db9be75c008017ff843b49912a43a40020d857a6654890b8293df305c012058369e45f78 SHA512 91e03f706ff91172a64fb9ab06544e39fcec90890074fbf72758b3bbc4d8664f66a7f714ccac5d3d236464485abef85d7936aba1612559a5c1dd78a505abd328
DIST dmd.2.089.1.linux.tar.xz 25877024 BLAKE2B 38fdbac595a6d9ea7548ee331aacefec530594be750a1b3dbfad7af8a5e310d6fb5e774106adfaa0d0c33cfec8e94c7a29f4c3c5c3088cc827f6ccd8a3472e56 SHA512 8a5343060d7f28394be81d8732997d96a23522c87912f2c8d0979375297467068d093ab4ef2b92b0ce8be941b5c65061660eef8d1e9252c626197014ac4331a9
+DIST dmd.2.090.0.linux.tar.xz 25586392 BLAKE2B ca07a292dd27766b6ce08423bf3f943b177cae7393f3d5e3f5322b694fb40852b4deb6fbc90c68506f52a2be6b39a2bc1003da186247dcbdd9f80f066091fd19 SHA512 bdfa7a9b6c41aad1555e36469746bf1d5c567ec59b291ea5c8d03597677bcbb3d0fa7f3649242494fd6021681343601418ccbbe4be0667ab87b58ee77a903468
diff --git a/dev-lang/dmd/dmd-2.088.1-r1.ebuild b/dev-lang/dmd/dmd-2.088.1-r1.ebuild
index 785eb6b..e651c15 100644
--- a/dev-lang/dmd/dmd-2.088.1-r1.ebuild
+++ b/dev-lang/dmd/dmd-2.088.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -18,7 +18,4 @@ dmd_src_prepare_extra() {
# Copy default DDOC theme file into resource directory
mkdir "dmd/res" || die "Failed to create 'dmd/res' directory"
cp "${FILESDIR}/2.086-default_ddoc_theme.ddoc" "dmd/res/default_ddoc_theme.ddoc" || die "Failed to copy 'default_ddoc_theme.ddoc' file into 'src/res' directory."
-
- # Copy missing config.d
- cp "${FILESDIR}/2.086-config.d" "dmd/config.d" || die "Failed to copy 'config.d' file into 'dmd' directory."
}
diff --git a/dev-lang/dmd/dmd-2.089.0-r1.ebuild b/dev-lang/dmd/dmd-2.089.0-r1.ebuild
index 1350dea..98c8e5b 100644
--- a/dev-lang/dmd/dmd-2.089.0-r1.ebuild
+++ b/dev-lang/dmd/dmd-2.089.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -18,7 +18,4 @@ dmd_src_prepare_extra() {
# Copy default DDOC theme file into resource directory
mkdir "dmd/res" || die "Failed to create 'dmd/res' directory"
cp "${FILESDIR}/2.086-default_ddoc_theme.ddoc" "dmd/res/default_ddoc_theme.ddoc" || die "Failed to copy 'default_ddoc_theme.ddoc' file into 'src/res' directory."
-
- # Copy missing config.d
- cp "${FILESDIR}/2.086-config.d" "dmd/config.d" || die "Failed to copy 'config.d' file into 'dmd' directory."
}
diff --git a/dev-lang/dmd/dmd-2.089.1.ebuild b/dev-lang/dmd/dmd-2.089.1.ebuild
index 1350dea..98c8e5b 100644
--- a/dev-lang/dmd/dmd-2.089.1.ebuild
+++ b/dev-lang/dmd/dmd-2.089.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -18,7 +18,4 @@ dmd_src_prepare_extra() {
# Copy default DDOC theme file into resource directory
mkdir "dmd/res" || die "Failed to create 'dmd/res' directory"
cp "${FILESDIR}/2.086-default_ddoc_theme.ddoc" "dmd/res/default_ddoc_theme.ddoc" || die "Failed to copy 'default_ddoc_theme.ddoc' file into 'src/res' directory."
-
- # Copy missing config.d
- cp "${FILESDIR}/2.086-config.d" "dmd/config.d" || die "Failed to copy 'config.d' file into 'dmd' directory."
}
diff --git a/dev-lang/dmd/dmd-2.090.0.ebuild b/dev-lang/dmd/dmd-2.090.0.ebuild
new file mode 100644
index 0000000..6b582a8
--- /dev/null
+++ b/dev-lang/dmd/dmd-2.090.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KEYWORDS="-* ~amd64 ~x86"
+YEAR=2020
+DLANG_VERSION_RANGE="2.076-"
+
+inherit dmd
+
+PATCHES=(
+ "${FILESDIR}/2.083-link-32-bit-shared-lib-with-ld.bfd.patch"
+)
+
+dmd_src_prepare_extra() {
+ # Copy default DDOC theme file into resource directory
+ mkdir "dmd/res" || die "Failed to create 'dmd/res' directory"
+ cp "${FILESDIR}/2.086-default_ddoc_theme.ddoc" "dmd/res/default_ddoc_theme.ddoc" || die "Failed to copy 'default_ddoc_theme.ddoc' file into 'src/res' directory."
+}
diff --git a/dev-util/dlang-tools/Manifest b/dev-util/dlang-tools/Manifest
index 106802c..fc2ba53 100644
--- a/dev-util/dlang-tools/Manifest
+++ b/dev-util/dlang-tools/Manifest
@@ -25,6 +25,7 @@ DIST dlang-tools-2.087.1.tar.gz 117096 BLAKE2B 3384882ff647c459d2a2380d35cf355ea
DIST dlang-tools-2.088.1.tar.gz 117104 BLAKE2B 2920cb8950fb0e921665bab161584c35a267acbc4a34713afabfab2edc40c6d391a2a55ae2bb3a0f28f2be2ef5ddbeec767b9afcea510d9b35d57d1cf9e5ca52 SHA512 288739656404e345e683e6692a6478a03af8455d3e3ad56d3ba22e1d7d9cb1e5156f70116e4444138c798bfa28cf4b38263b6cd32a8d2483417e8ae51192ea65
DIST dlang-tools-2.089.0.tar.gz 117576 BLAKE2B 73ff760a86bd537e8ae818287bd337c25a865c2a103ad7334f66abc02725b064b1190c2bdc29b32d6b3759adc69a36a2ac499285aef3f1c4b260f4d747750418 SHA512 a64bed8d0b24a33fd86ca1375895f85cd86b34d2b9eb871e7d3df34235e634be058addd6b1056c5a3b010050eb0593e5ef45d907720e07b081140fd265bc00e3
DIST dlang-tools-2.089.1.tar.gz 117693 BLAKE2B 6e499fd01bda7a58036b08f30319549ca2c786ea348ac93d045019fde745a3b30179af0d7c3999af8bd09f15d86876e43927cf069a70dc5120ebc08eb82a84c3 SHA512 ffc1eb9d42f167d2a519a052fdc87fb3db576d9b549dac80c993859f597dfbc492e783129b9c94dc664e33817bacf09b040d0cb2efbc679971ba768163eb4e42
+DIST dlang-tools-2.090.0.tar.gz 117713 BLAKE2B efe720acfa306f6dc29e42ff13d23c3298aeed00429913b962b246143c688b4d839936e859c07d4d624430a5043c69205aef363face14875292ee52d968f6006 SHA512 b861fc11fe7ed105439984c79001fdef63da4d03fe751f0b43eb478a38afeab3599ffb41f39451faea71e4bb44e3d871a9ce41d45d8e19f4e59d5565efd6264e
DIST dlang.org-2.064.2.tar.gz 963131 BLAKE2B a7cf0d43a1cd531722bda717882a34e01c0186f0832a12064bf0600aede0a0913190724011f0b13c76cf794434e1c82490f48e9fda66409aa2820adc7c8a40f9 SHA512 a1284955764385539dcd8949cd851100af9be47908e85d8cfd897d6409903763919dc082fc0ca88fbaaf49647168357656aee82717a375ed45407eb15ccd44cf
DIST dlang.org-2.065.0.tar.gz 1005429 BLAKE2B 01fc8ec0c5148f910e2923be556208c08a18f00453ffa1f1a22d6725db6489b6f9022cd170caa3a05078baddde353ee819984da5efa53547e78006d2f0a97b9c SHA512 0fb185603766b54c3b9dc57824b18ec7ea9f37281610729860543630f4546591f9523bff48eee5414235d2ee656201c444e6d2efc44ba66a052b98a0d9b4729e
DIST dlang.org-2.066.1.tar.gz 1024075 BLAKE2B cfdb4922c38d9f0ced941eeb4578d71f09d65201d2f89cfc73e46ae73f0939c74fa92d7f003b87a28f814c5b2cc0dda6855b86e64fd86be3920c129f8c20df6a SHA512 d3838cc2ab6236d57c17f92fa5eaef8458176715985aecbea9653cc772725e1b9f813c9ffc8e06490e08c1031826ab84d1fcfbd88008791cac3257db814e3dc8
diff --git a/dev-util/dlang-tools/dlang-tools-2.090.0.ebuild b/dev-util/dlang-tools/dlang-tools-2.090.0.ebuild
new file mode 100644
index 0000000..6b8a8e1
--- /dev/null
+++ b/dev-util/dlang-tools/dlang-tools-2.090.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Ancilliary tools for the D programming language compiler"
+HOMEPAGE="http://dlang.org/"
+LICENSE="Boost-1.0"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+TOOLS="ddemangle detab dustmite rdmd"
+IUSE="+ddemangle detab dustmite +rdmd"
+REQUIRED_USE="|| ( ${TOOLS} )"
+
+inherit eapi7-ver
+
+DLANG_SLOT="$(ver_cut 1-2)"
+RESTRICT="mirror"
+
+BETA="$(ver_cut 4)"
+VERSION="$(ver_cut 1-3)"
+
+if [[ -n "${BETA}" ]]; then
+ VERSION="${VERSION}-b${BETA:4}"
+fi
+SRC_URI="https://codeload.github.com/dlang/tools/tar.gz/v${VERSION} -> dlang-tools-${VERSION}.tar.gz"
+
+DLANG_VERSION_RANGE="2.076-"
+DLANG_PACKAGE_TYPE="single"
+
+inherit eutils dlang
+
+S="${WORKDIR}/tools-${VERSION}"
+
+d_src_compile() {
+ use ddemangle && dlang_compile_bin ddemangle ddemangle.d
+ use detab && dlang_compile_bin detab detab.d
+ use dustmite && dlang_compile_bin dustmite DustMite/dustmite.d DustMite/splitter.d
+ use rdmd && dlang_compile_bin rdmd rdmd.d
+}
+
+d_src_install() {
+ for tool in ${TOOLS}; do
+ if use "${tool}"; then
+ dobin "${tool}"
+ fi
+ done
+
+ # file icons
+ for size in 16 22 24 32 48 256; do
+ newicon --size "${size}" --context mimetypes "${FILESDIR}/icons/${size}/dmd-source.png" text-x-dsrc.png
+ done
+}
diff --git a/dev-util/dub/Manifest b/dev-util/dub/Manifest
index 4c83fb9..cc14675 100644
--- a/dev-util/dub/Manifest
+++ b/dev-util/dub/Manifest
@@ -1 +1,2 @@
DIST dub-1.18.0.tar.gz 1281488 BLAKE2B 69c1c2c10c4f3ede1fd30f31d87d135c0bc7435fddd14491ec86fc8a86e61e91a89b678ee32f11dbe180ed710859917a6c7a3de8900b4a0f7696bb3a4ffd13b4 SHA512 c8eff9e9fe1edf5f2cb01119463dade936f32f53971e9d58dad6e3d27cc2a013cd9bb6976d2d42c999b7c98a4bd8f9846a2064ba6496c9c1a6dc5e15421c9cfa
+DIST dub-1.19.0.tar.gz 1283024 BLAKE2B 7deace0bf350e5f9b1f3fd6570c41ccb48dcf80cd501ec9bcea8b0e0737f16177eaefa0b34eba9b947283e77fd80c7f5d84dcc46904ebecdce50b1d73928a3ec SHA512 65e31f967939914790e65515fc460510336857aa6273db1a8e75681bf1182d25019f70ca050aa221679e9ccdd10edd3757f1629cd0686af6b584c8439057edc8
diff --git a/dev-util/dub/dub-1.19.0.ebuild b/dev-util/dub/dub-1.19.0.ebuild
new file mode 100644
index 0000000..23205f6
--- /dev/null
+++ b/dev-util/dub/dub-1.19.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Package and build management system for D"
+HOMEPAGE="http://code.dlang.org/"
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="debug"
+
+GITHUB_URI="https://codeload.github.com/dlang"
+SRC_URI="${GITHUB_URI}/${PN}/tar.gz/v${PV} -> ${PN}-${PV}.tar.gz"
+PATCHES="${FILESDIR}/${P}-gdc-dmd-pathfix.patch"
+
+DLANG_VERSION_RANGE="2.076-"
+DLANG_PACKAGE_TYPE="single"
+
+inherit dlang
+
+DEPEND="net-misc/curl"
+RDEPEND="${DEPEND}"
+
+d_src_compile() {
+ local imports=source versions="DubApplication DubUseCurl" libs="curl z"
+ dlang_compile_bin bin/dub $(<build-files.txt)
+}
+
+d_src_test() {
+ echo "Test phase disabled due to multiple problems."
+ #DUB="${S}/bin/dub" test/run-unittest.sh || die "Test phase failed"
+}
+
+d_src_install() {
+ dobin bin/dub
+ dodoc README.md
+}
diff --git a/dev-util/dub/files/dub-1.19.0-gdc-dmd-pathfix.patch b/dev-util/dub/files/dub-1.19.0-gdc-dmd-pathfix.patch
new file mode 100644
index 0000000..497ef50
--- /dev/null
+++ b/dev-util/dub/files/dub-1.19.0-gdc-dmd-pathfix.patch
@@ -0,0 +1,16 @@
+diff --git a/source/dub/generators/build.d b/source/dub/generators/build.d
+--- a/source/dub/generators/build.d
++++ b/source/dub/generators/build.d
+@@ -119,10 +119,10 @@ class BuildGenerator : ProjectGenerator {
+ auto build_id = computeBuildID(config, buildsettings, settings);
+
+ // make all paths relative to shrink the command line
+- string makeRelative(string path) { return shrinkPath(NativePath(path), cwd); }
++ /+string makeRelative(string path) { return shrinkPath(NativePath(path), cwd); }
+ foreach (ref f; buildsettings.sourceFiles) f = makeRelative(f);
+ foreach (ref p; buildsettings.importPaths) p = makeRelative(p);
+- foreach (ref p; buildsettings.stringImportPaths) p = makeRelative(p);
++ foreach (ref p; buildsettings.stringImportPaths) p = makeRelative(p);+/
+
+ // perform the actual build
+ bool cached = false;
diff --git a/eclass/dmd.eclass b/eclass/dmd.eclass
index 682a82a..18d260f 100644
--- a/eclass/dmd.eclass
+++ b/eclass/dmd.eclass
@@ -130,7 +130,7 @@ dmd_src_compile() {
dmd_ge 2.071 && HOST_CXX="HOST_CXX" || HOST_CXX="HOST_CC"
# 2.072 and 2.073 have support for LTO, but would need a Makefile patch.
# From 2.088 on, the build fails with it active.
- dmd_ge 2.074 && ! dmd_eq 2.088 && ! dmd_eq 2.089 && LTO="ENABLE_LTO=1"
+ dmd_ge 2.074 && ! dmd_eq 2.088 && ! dmd_eq 2.089 && ! dmd_eq 2.090 && LTO="ENABLE_LTO=1"
# 2.080 and below used RELEASE instead of ENABLE_RELEASE
dmd_ge 2.081 && ENABLE_RELEASE="ENABLE_RELEASE" || ENABLE_RELEASE="RELEASE"