summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--decisions/.gitignore1
-rw-r--r--decisions/Makefile5
-rw-r--r--decisions/decisions.but32
-rw-r--r--decisions/decisions.tex11
-rwxr-xr-xdecisions/makebugs4
-rw-r--r--decisions/summary-20151108.tex10
-rw-r--r--decisions/summary-20151213.tex11
-rw-r--r--decisions/summary-20160110.tex11
-rw-r--r--decisions/summary-20160214.tex15
-rw-r--r--decisions/summary-20160313.tex10
-rw-r--r--decisions/summary-20160410.tex11
-rw-r--r--decisions/summary-20160508.tex6
-rw-r--r--decisions/summary-20160710.tex14
-rw-r--r--decisions/summary-20160814.tex9
-rw-r--r--decisions/summary-20160911.tex10
-rw-r--r--decisions/summary-20161009.tex8
-rw-r--r--decisions/summary-20161113.tex14
17 files changed, 115 insertions, 67 deletions
diff --git a/decisions/.gitignore b/decisions/.gitignore
index 9549470..9af01ad 100644
--- a/decisions/.gitignore
+++ b/decisions/.gitignore
@@ -8,5 +8,4 @@ decisions.pdf
decisions.toc
decisions.bug
decisions.bur
-decisions.but
summary-*.aux
diff --git a/decisions/Makefile b/decisions/Makefile
index 0ae1bd6..b27289c 100644
--- a/decisions/Makefile
+++ b/decisions/Makefile
@@ -8,5 +8,8 @@ default: decisions.pdf
decisions.ind: *.aux *.tex
makeindex decisions
-decisions.pdf: *.aux *.idx *.tex *.ind
+decisions.bug: decisions.but
+ ./makebug
+
+decisions.pdf: *.aux *.idx *.tex *.ind *.bug
pdflatex decisions
diff --git a/decisions/decisions.but b/decisions/decisions.but
new file mode 100644
index 0000000..331c401
--- /dev/null
+++ b/decisions/decisions.but
@@ -0,0 +1,32 @@
+579460
+please make repoman ignore a missing "# $Id$" header line
+590972
+repoman should prevent people from adding a new package with a metadata.xml pointing to maintained-needed directly
+571490
+Missing summary for 20151025 council meeting
+282296
+[Future EAPI] Allow directories for use.* and package.* entries in profiles
+503382
+Missing summaries for 20131210, 20140114, and 20140225 council meetings
+574952
+Extremely uncooperative behavior from games team
+574082
+[TRACKER] games.eclass deprecation
+575534
+Editing on XS screens
+566498
+games.eclass: use of games group needs to be removed wrt 20151011 Council meeting
+569914
+Missing summary for 20150727 council meeting
+565700
+Approve EAPI 6
+174407
+[Future EAPI] add support for dynamic SLOTS
+568068
+GLEP 42: Define support for EAPI 5 dependency atoms in news items
+596678
+Missing log and summary for council meeting 2016-09-11 & 2016-10-09
+574080
+games.eclass: Path customization needs to be removed wrt 20151213 Council meeting
+565566
+New ChangeLogs are in chronological order
diff --git a/decisions/decisions.tex b/decisions/decisions.tex
index 2bf6cf0..776e67a 100644
--- a/decisions/decisions.tex
+++ b/decisions/decisions.tex
@@ -12,7 +12,16 @@
\usepackage[pdfpagelabels=true,breaklinks=true]{hyperref}
\usepackage{breakcites}
\usepackage{textcomp}
+\usepackage{datetime}
+\newcommand{\summary}[3]{
+ \section{#3\ \protect\monthname[#2]\ #1}
+ \officiallogs{#1\twodigit{#2}\twodigit{#3}}
+}
+
+\newcommand{\agendaitem}[1]{
+ \subsection{#1}
+}
\newcommand{\gentoobugifnotempty}[2]{%
\sbox0{#1}%
@@ -60,6 +69,8 @@ council meeting} and the
summary}.
}
+
+
\definecolor{darkblue}{rgb}{0,0,0.7}
\definecolor{darkred}{rgb}{0.7,0,0}
diff --git a/decisions/makebugs b/decisions/makebugs
index 972a6fb..09838cf 100755
--- a/decisions/makebugs
+++ b/decisions/makebugs
@@ -25,7 +25,6 @@ sub getbugtitle {
my $soapresult = $proxy->call('Bug.get', { ids => [$number] });
my $result = $soapresult->result;
my $bug = $result->{bugs}->[0];
- print Dumper \$bug;
my $summary = $bug->{summary};
return $summary;
}
@@ -61,10 +60,11 @@ foreach(@bugnumbers) {
my $cur=$_;
print "Bug number $cur\n";
if ($bugtitles{$cur}) {
- print " Title is $bugtitles{$cur}\n";
+ print " Title is \"$bugtitles{$cur}\"\n";
} else {
print " Title not yet available, fetching it\n";
$bugtitles{$cur}=getbugtitle($cur);
+ print " Result is \"$bugtitles{$cur}\"\n";
};
};
diff --git a/decisions/summary-20151108.tex b/decisions/summary-20151108.tex
index 7e393b0..6786a4e 100644
--- a/decisions/summary-20151108.tex
+++ b/decisions/summary-20151108.tex
@@ -1,7 +1,7 @@
-\section{8 November 2015}
-\officiallogs{20151008}
-\subsection{EAPI 6 approval}
+\summary{2015}{11}{8}
+
+\agendaitem{EAPI 6 approval}
\index{EAPI!6}
Reference: \agoref{gentoo-project}{f78e316074897a604842fe13d2860be6}
@@ -19,13 +19,13 @@ discussion an amendment was accepted to sanitize LC\_CTYPE and
LC\_COLLATE settings to ensure that certain casemod operators of
Bash 4 can be used.
-\subsection{Bugs with council involvement}
+\agendaitem{Bugs with council involvement}
\bug{503382}, but as this has been discussed before nothing new was
added in this meeting.
-\subsection{Open floor}
+\agendaitem{Open floor}
\index{ChangeLog!generation}\index{ChangeLog!sort order}
ChangeLog generation and order of entries was discussed briefly during
diff --git a/decisions/summary-20151213.tex b/decisions/summary-20151213.tex
index 3ad81ea..da533e3 100644
--- a/decisions/summary-20151213.tex
+++ b/decisions/summary-20151213.tex
@@ -1,6 +1,7 @@
-\section{13 December 2015}
-\subsection{Games file-path policy}
+\summary{2015}{12}{13}
+
+\agendaitem{Games file-path policy}
\index{EAPI!6}\index{games!file paths}\index{eclass!games.eclass}
References:
@@ -22,7 +23,7 @@ inherit the current games eclass. Following this a vote was held on
whether "EAPI 6 should be blocked in the current games eclass", which
passed with a vote count of 4 yes, 2 no and 1 abstainations.
-\subsection{Review, and possibly vote on GLEP 67}
+\agendaitem{Review, and possibly vote on GLEP 67}
Reference: \agoref{gentoo-project}{effdb2474965825fdfc06d0276e3318d}
@@ -30,13 +31,13 @@ The council unanumously voted in favor of "The council approves the
general direction of \glep{67} but notes that minor alterations might
be needed to provide clarity before final approval"
-\subsection{Bugs with council involvement}
+\agendaitem{Bugs with council involvement}
The council briefly discussed \bug{503382}. The current status
of this bug is a missing summary for the 20140225 meeting. Ulm has
volunteered to write this and it is ongoing.
-\subsection{Open floor}
+\agendaitem{Open floor}
\index{EAPI!5}\index{news item}
The council discussed \bug{568068}. It was a concensus for defining a new
diff --git a/decisions/summary-20160110.tex b/decisions/summary-20160110.tex
index dd5a7c8..419b3e4 100644
--- a/decisions/summary-20160110.tex
+++ b/decisions/summary-20160110.tex
@@ -1,6 +1,7 @@
-\section{10 January 2016}
-\subsection{Further discussion on GLEP 67}
+\summary{2016}{1}{10}
+
+\agendaitem{Further discussion on GLEP 67}
References:
\begin{itemize}
@@ -33,7 +34,7 @@ to be the 24th January 2016. All remaining herds will be dropped after that and
the remaining packages will be assigned to maintainer-needed.}{Approved
unanimously.}
-\subsection{Banning of EAPI 0 \& 3 for new ebuilds}
+\agendaitem{Banning of EAPI 0 \& 3 for new ebuilds}
\index{EAPI!0}\index{EAPI!3}\index{EAPI!1}
References:
@@ -51,7 +52,7 @@ Further the Council decided unanimously to amend the ban of EAPI
1 \& 2 made in the Council meeting 2014-03-11. To this effect, the
exception of updating EAPI=0 ebuilds to EAPI=1 is dropped.
-\subsection{Bugs with council involvement}
+\agendaitem{Bugs with council involvement}
\index{news item!format 1.1}
\begin{itemize}
@@ -69,7 +70,7 @@ public transparency for the size of the change has been enough. The Council
unanimously approved the new format.
\end{itemize}
-\subsection{Open floor}
+\agendaitem{Open floor}
A short information exchange about the presence of Gentoo Linux at the 2016
FOSDEM has happened but further discussion has been moved to \#gentoo-fosdem
diff --git a/decisions/summary-20160214.tex b/decisions/summary-20160214.tex
index 9b78130..ce63e5e 100644
--- a/decisions/summary-20160214.tex
+++ b/decisions/summary-20160214.tex
@@ -1,6 +1,7 @@
-\section{14 February 2016}
-\subsection{Options for new XML validation language}\index{XML validation}
+\summary{2016}{2}{14}
+
+\agendaitem{Options for new XML validation language}\index{XML validation}
References:
\begin{itemize}
@@ -25,7 +26,7 @@ Any further decision have been postponed until better metrics are available.
Michał Górny volunteered to do some research on the output of all three
validators.
-\subsection{Discuss situation of libressl support maintenance}\index{LibreSSL}
+\agendaitem{Discuss situation of libressl support maintenance}\index{LibreSSL}
Reference: \agoref{gentoo-project}{dc5406af670aebc050362fcbd8cd528e}
@@ -55,7 +56,7 @@ Some question which arise and should be answered by the project comprise
maintains the necessary patches?
\end{itemize}
-\subsection{Automatic bug assignments}\index{Bug assignment}\index{Bug wrangling}
+\agendaitem{Automatic bug assignments}\index{Bug assignment}\index{Bug wrangling}
Reference: \agoref{gentoo-project}{00e02ff494857599633e2bbc30520ca3}
@@ -65,7 +66,7 @@ point the Council sees no reason for any decision to be made itself.
The community or the bug wrangling project should draft an implementation.
-\subsection{The usage of use() in global scope violates PMS}\index{use()}\index{PMS}\index{Dynamic SLOT}
+\agendaitem{The usage of use() in global scope violates PMS}\index{use()}\index{PMS}\index{Dynamic SLOT}
Reference: \agoref{gentoo-project}{69ed522b3b53de90e616267a77441012}
@@ -78,7 +79,7 @@ This decision renders the proposed solution for dynamic SLOTs, \bug{174407},
impossible.
This topic was deferred to a later meeting to give time for an alternative solution to be found.
-\subsection{Bugs with council involvement}
+\agendaitem{Bugs with council involvement}
\begin{itemize}
\item \bug{569914}:
@@ -90,7 +91,7 @@ The only open question is if the new news item format should include a
Display-If-Visible header.
\end{itemize}
-\subsection{Open floor}
+\agendaitem{Open floor}
No items were brought forward.
diff --git a/decisions/summary-20160313.tex b/decisions/summary-20160313.tex
index a3290a9..bf0d82e 100644
--- a/decisions/summary-20160313.tex
+++ b/decisions/summary-20160313.tex
@@ -1,7 +1,7 @@
-\section{13 March 2016}
+\summary{2016}{3}{13}
-\subsection{GLEP 42 update}
+\agendaitem{GLEP 42 update}
The Council considered ulm’s proposed extension of the News Item Format as
specified in \glep{42} to allow EAPI=5 style package dependency specifications,
@@ -10,7 +10,7 @@ see \agoref{gentoo-dev}{b9460b9c8d578c3498c217c17b75afd4}-
The Council unanimously approved the changes. This introduces “News item format
2.0”.
-\subsection{Historical behaviour vs PMS}\index{PMS}
+\agendaitem{Historical behaviour vs PMS}\index{PMS}
The Council considered the question of how to deal with historical behavior of
packages/eclasses and package managers that are not in compliance with PMS and
@@ -25,7 +25,7 @@ however no current reason why that should continue. If in any specific issue no
progress at all is reached within 6 months, proposing the best technical
solution is delegated to QA."
-\subsection{Bugs with council involvement}
+\agendaitem{Bugs with council involvement}
\begin{itemize}
\item \bug{575534}:
@@ -38,7 +38,7 @@ Team to take action. It was suggested that QA act to correct the paths in the
games.eclass.
\end{itemize}
-\subsection{Open floor}
+\agendaitem{Open floor}
As a follow up on the discussion of the previous meeting about hasufell, blueness
announced a new project, the LibreSSL project with members blueness, dilfridge,
diff --git a/decisions/summary-20160410.tex b/decisions/summary-20160410.tex
index 50d9388..bf688b1 100644
--- a/decisions/summary-20160410.tex
+++ b/decisions/summary-20160410.tex
@@ -1,6 +1,7 @@
-\section{10 April 2016}
-\subsection{Approval of GLEP 68}
+\summary{2016}{4}{10}
+
+\agendaitem{Approval of GLEP 68}
\index{Language codes}
Reference: \agoref{gentoo-project}{a292e9567fac838681899b50dff24cce}
@@ -13,7 +14,7 @@ This can be reconsidered when a real need for extension should arise.
\item Vote: Approval of \glep{68}. Accepted unanimously.
\end{itemize}
-\subsection{ChangeLog files in rsync tree}
+\agendaitem{ChangeLog files in rsync tree}
\index{ChangeLog files}\index{rsync tree}\index{ChangeLog sort order}
Reference: \agoref{gentoo-project}{402eb403e0f451e7bc0525b76e9d3da2}
@@ -33,7 +34,7 @@ order of ChangeLog entries.
newest entries first}{Accepted (4 yes, 2 no, 1 abstention)}
\end{itemize}
-\subsection{Bugs with council involvement}
+\agendaitem{Bugs with council involvement}
\index{eclass!games.eclass}
\begin{itemize}
@@ -46,6 +47,6 @@ order of ChangeLog entries.
that CVS headers can be dropped.
\end{itemize}
-\subsection{Open floor}
+\agendaitem{Open floor}
No issues were brought forward.
diff --git a/decisions/summary-20160508.tex b/decisions/summary-20160508.tex
index ca91b9e..a68a68f 100644
--- a/decisions/summary-20160508.tex
+++ b/decisions/summary-20160508.tex
@@ -1,7 +1,7 @@
-\section{8 May 2016}
+\summary{2016}{5}{8}
-\subsection{Bugs with council involvement}
+\agendaitem{Bugs with council involvement}
These bugs have to do with games issues:
@@ -23,7 +23,7 @@ for tracking:
\item\bug{571490}
\end{itemize}
-\subsection{Open floor}
+\agendaitem{Open floor}
\index{use flag!gtk}
Williamh brought up the gtk use flag situation; it was referred to the qa team.
diff --git a/decisions/summary-20160710.tex b/decisions/summary-20160710.tex
index 988313c..43e8286 100644
--- a/decisions/summary-20160710.tex
+++ b/decisions/summary-20160710.tex
@@ -1,21 +1,21 @@
-\section{10 July 2016}
-\officiallogs{20160710}
-\subsection{Meeting schedule}
+\summary{2016}{7}{10}
+
+\agendaitem{Meeting schedule}
\vote{Hold meetings every 2nd Sunday of the month at 19:00 UTC.}{Accepted
unanimously.}
-\subsection{Work flow}
+\agendaitem{Work flow}
\vote{Continue last council's workflow considering sending call for
agenda items (2 weeks in advance), sending the agenda (1 week in
advance) and have the meeting focussed, e.g., have major discussions
on -project ML prior to the meeting.}{Accepted unanimously.}
-\subsection{Meeting chairs}
+\agendaitem{Meeting chairs}
Meeting chairs for the upcoming council term have been assigned.
-\subsection{Bugs with council involvement}
+\agendaitem{Bugs with council involvement}
\begin{itemize}
\item
@@ -30,7 +30,7 @@ ComRel.
\end{itemize}
-\subsection{Open floor}
+\agendaitem{Open floor}
\index{maintainer-needed!packages}
\index{ComRel}
diff --git a/decisions/summary-20160814.tex b/decisions/summary-20160814.tex
index 45dcf77..bef20f2 100644
--- a/decisions/summary-20160814.tex
+++ b/decisions/summary-20160814.tex
@@ -1,8 +1,7 @@
-\section{14th August 2016}
-\officiallogs{20160814}
+\summary{2016}{8}{14}
-\subsection{Discussion on the state of the stable tree}
+\agendaitem{Discussion on the state of the stable tree}
\index{stabilization}\index{stable workgroup}
Reference: \agoref{gentoo-project}{fb5d6fe4d6f84eeb5fedff2e968675fb}
@@ -12,7 +11,7 @@ and the Council decided on setting up a Working Group (WG) chaired by K\_F to
continue discussions and come back to the Council with recommendations at a
later meeting on how to improve the state of the stable tree.
-\subsection{Bugs with council involvement}
+\agendaitem{Bugs with council involvement}
\index{maintainer-needed}
The \bug{590972} was discussed. Adding a repoman check to stop addition of new
@@ -24,7 +23,7 @@ The Council walked through the rest of the list of bugs listed for Council
action and concluded that no new action that requires Council attention at
this time has come up with them.
-\subsection{Open floor}
+\agendaitem{Open floor}
It was briefly discussed whether an infra-side git push check could mitigate
issues such as the one discussed in \bug{590972}, but it was concensus that such
diff --git a/decisions/summary-20160911.tex b/decisions/summary-20160911.tex
index d6daeea..f98cab0 100644
--- a/decisions/summary-20160911.tex
+++ b/decisions/summary-20160911.tex
@@ -1,7 +1,7 @@
-\section{11 September 2016}
-\officiallogs{20160911}
-\subsection{RFC: Eclasses and EAPI}
+\summary{2016}{9}{11}
+
+\agendaitem{RFC: Eclasses and EAPI}
\index{eclasses}\index{EAPI!support in eclasses}
Reference: \agoref{gentoo-dev}{87e630b9da724c5c59060608aba596a9}
@@ -21,7 +21,7 @@ this e.g. perl.
Nothing has been decided on this matter by the council in this meeting.
-\subsection{Bugs with council involvement}
+\agendaitem{Bugs with council involvement}
\begin{itemize}
\item
@@ -35,6 +35,6 @@ Nothing has been decided on this matter by the council in this meeting.
\bug{565566}: Action from Infra missing, council will ping Infra for update
\end{itemize}
-\subsection{Open floor}
+\agendaitem{Open floor}
No items were brought up.
diff --git a/decisions/summary-20161009.tex b/decisions/summary-20161009.tex
index c9752d2..3829d09 100644
--- a/decisions/summary-20161009.tex
+++ b/decisions/summary-20161009.tex
@@ -1,14 +1,14 @@
-\section{9 October 2016}
-\officiallogs{20161009}
-\subsection{Bugs with council involvement}
+\summary{2016}{10}{9}
+
+\agendaitem{Bugs with council involvement}
\index{ChangeLog!sort order}
ulm followed \bug{565566} up with robbat2. robbat2 is working on the
historical git conversion, but no ETA for the fix yet. council invites Infra to
give some more insights at the next meeting.
-\subsection{Open floor}
+\agendaitem{Open floor}
\index{graveyard overlay}
WilliamH wanted the council discuss the availability of the graveyard overlay
diff --git a/decisions/summary-20161113.tex b/decisions/summary-20161113.tex
index b01a959..0cc4073 100644
--- a/decisions/summary-20161113.tex
+++ b/decisions/summary-20161113.tex
@@ -1,7 +1,7 @@
-\section{13 November 2016}
-\officiallogs{20161113}
-\subsection{Stabilisation workflow}
+\summary{2016}{11}{13}
+
+\agendaitem{Stabilisation workflow}
\index{stabilization}\index{bugzilla workflow}
Reference: \agoref{gentoo-project}{1ccf2b07b96f4b164e6f69fb5d2d6cc7}
@@ -12,7 +12,7 @@ the status report sent to the gentoo-project mailing list by K\_F
An update to \glep{40} and a change of the bugzilla workflow are likely
to be proposed. No council action to be taken, for the time being.
-\subsection{Status of contributors}
+\agendaitem{Status of contributors}
\index{Foundation!bylaws}\index{umbrella organization}
Reference: \agoref{gentoo-project}{4a88db38253494c6612a29117b2b19c8}
@@ -24,7 +24,7 @@ needs solving. The option of associating with an umbrella organisation
(like SPI) was mentioned. No motion was voted upon, and the topic was
tabled for a later meeting.
-\subsection{Copyright matters}
+\agendaitem{Copyright matters}
\index{copyright}
Reference: \agoref{gentoo-project}{60481da5b44b778ca5c4405da28f61c7}
@@ -32,7 +32,7 @@ Reference: \agoref{gentoo-project}{60481da5b44b778ca5c4405da28f61c7}
There is agreement that copyright issues are a task for the
foundation, therefore the council will not take any action.
-\subsection{Bugs with council involvement}
+\agendaitem{Bugs with council involvement}
\begin{itemize}
\item
@@ -56,7 +56,7 @@ foundation, therefore the council will not take any action.
Ordering of entries will be reversed thereafter.
\end{itemize}
-\subsection{Open floor}
+\agendaitem{Open floor}
\index{stabilization!arches}\index{FOSDEM}
\begin{itemize}