summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRussell Harmon <russ@eatnumber1.com>2011-01-08 12:25:54 -0500
committerRussell Harmon <russ@eatnumber1.com>2011-01-08 12:25:54 -0500
commitc5ed15a916826a80c191262d45d5ba8fd038d393 (patch)
tree80ce3ec2d04648d8d6096d399fb27d4c8f291179 /net-im/gajim/gajim-9999.ebuild
parentdwarf-fortress-0.28.181.40d.ebuild is actually dwarf-fortress-0.28.181.40d-r1... (diff)
parenttkpath ebuild; idea-community version bump; idea-ultimate ebuild (diff)
downloadeatnumber1-c5ed15a916826a80c191262d45d5ba8fd038d393.tar.gz
eatnumber1-c5ed15a916826a80c191262d45d5ba8fd038d393.tar.bz2
eatnumber1-c5ed15a916826a80c191262d45d5ba8fd038d393.zip
Merge branch 'master' of github.com:eatnumber1/eatnumber1-overlay
Conflicts: layman-local.cfg sys-libs/libhx/libhx-3.4.ebuild
Diffstat (limited to 'net-im/gajim/gajim-9999.ebuild')
-rw-r--r--net-im/gajim/gajim-9999.ebuild109
1 files changed, 109 insertions, 0 deletions
diff --git a/net-im/gajim/gajim-9999.ebuild b/net-im/gajim/gajim-9999.ebuild
new file mode 100644
index 0000000..8f245ec
--- /dev/null
+++ b/net-im/gajim/gajim-9999.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit eutils mercurial python multilib
+
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH="sqlite xml"
+
+EHG_REPO_URI="http://hg.gajim.org/gajim"
+#EHG_REVISION="default"
+#EHG_BOOTSTRAP="./autogen.sh"
+
+DESCRIPTION="Jabber client written in PyGTK"
+HOMEPAGE="http://www.gajim.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="avahi crypt dbus gnome idle jingle libnotify networkmanager nls spell srv X xhtml"
+
+COMMON_DEPEND="
+ x11-libs/gtk+:2
+ >=dev-python/pygtk-2.16.0"
+
+DEPEND="${COMMON_DEPEND}
+ >=sys-devel/gettext-0.17-r1
+ >=dev-util/intltool-0.40.1
+ dev-util/pkgconfig"
+
+RDEPEND="${COMMON_DEPEND}
+ dev-python/pyopenssl
+ dev-python/sexy-python
+ dev-python/pyxdg
+ crypt? (
+ app-crypt/gnupg
+ dev-python/pycrypto
+ )
+ dbus? (
+ dev-python/dbus-python
+ dev-libs/dbus-glib
+ libnotify? ( dev-python/notify-python )
+ avahi? ( net-dns/avahi[dbus,gtk,python] )
+ )
+ gnome? (
+ dev-python/libgnome-python
+ dev-python/gnome-keyring-python
+ dev-python/egg-python
+ )
+ idle? ( x11-libs/libXScrnSaver )
+ jingle? ( net-libs/farsight2[python] )
+ networkmanager? (
+ dev-python/dbus-python
+ || ( >=net-misc/networkmanager-0.7.1 net-misc/networkmanager[gnome] )
+ )
+ srv? (
+ || (
+ dev-python/libasyncns-python
+ net-dns/bind-tools )
+ )
+ spell? ( app-text/gtkspell )
+ xhtml? ( dev-python/docutils )"
+
+pkg_setup() {
+ if ! use dbus; then
+ if use libnotify; then
+ eerror "The dbus USE flag is required for libnotify support"
+ die "USE=\"dbus\" needed for libnotify support"
+ fi
+ if use avahi; then
+ eerror "The dbus USE flag is required for avahi support"
+ die "USE=\"dbus\" needed for avahi support"
+ fi
+ fi
+ python_pkg_setup
+ python_set_active_version 2
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/window_class.patch
+ ./autogen.sh || die "autogen.sh failed"
+ echo '#!/bin/sh' > config/py-compile
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_with X x) \
+ --docdir="/usr/share/doc/${PF}" \
+ --libdir="$(python_get_sitedir)" \
+ --enable-site-packages
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ rm "${D}/usr/share/doc/${PF}/"{README.html,COPYING} || die
+ dohtml README.html || die
+}
+
+pkg_postinst() {
+ python_mod_optimize $(python_get_sitedir)/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup $(python_get_sitedir)/${PN}
+}