aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2015-03-30 21:15:33 +0100
committerPaul Healy <lmiphay@gmail.com>2015-03-30 21:15:33 +0100
commit084404021c73604ef03d51c4cfd84cdcf9536b4e (patch)
treea434414bdc20aeaa597f6595ffd89153b54a5dd4 /kde-misc
parentadd ebuild for /containmentaction-favorites (diff)
downloadlmiphay-084404021c73604ef03d51c4cfd84cdcf9536b4e.tar.gz
lmiphay-084404021c73604ef03d51c4cfd84cdcf9536b4e.tar.bz2
lmiphay-084404021c73604ef03d51c4cfd84cdcf9536b4e.zip
add ebuild for scriptedhtml
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/scriptedhtml/Manifest2
-rw-r--r--kde-misc/scriptedhtml/files/CMakeLists.txt11
-rw-r--r--kde-misc/scriptedhtml/scriptedhtml-9999.ebuild27
3 files changed, 40 insertions, 0 deletions
diff --git a/kde-misc/scriptedhtml/Manifest b/kde-misc/scriptedhtml/Manifest
new file mode 100644
index 0000000..89462c8
--- /dev/null
+++ b/kde-misc/scriptedhtml/Manifest
@@ -0,0 +1,2 @@
+AUX CMakeLists.txt 317 SHA256 c3cff1c5765a7c0edcfea1e0fd6b8474561e35d2caa38165748302c674203074 SHA512 e846a4d68957244d4a722ff04bb5ba4ee64986f0b0ac83ee4ab66e756a9f02a1bd8a476e78ac1ede4dedb12a8154a98659c3577a090fd8e31d9818cd46b6286c WHIRLPOOL ad647c4892257bf6051d62b9a6fa4cd932434c872309a70f2ab168542e34159d9d2d760ec2426f0de08e93c9e6f76671b676abefc421ee0601516f22c14e8fbc
+EBUILD scriptedhtml-9999.ebuild 554 SHA256 032fb38728f2d0454695df3ec681810a413aaac065c85ec98282651d296786e6 SHA512 5ceba2e57186197393408419bbbc29ae03bd55d6519968134afcfa3614dd9feb09e05732e867593f55d68753dede1adef3079e3864c72e7906e4b5bd27223203 WHIRLPOOL c547b22f57213283598b28870bd3a5fe8b541570eddf3efe806d5eccb91dca63fa3ece940dd53f5b114c87e6e621e83026023578b640fb270a294aa7f03966f4
diff --git a/kde-misc/scriptedhtml/files/CMakeLists.txt b/kde-misc/scriptedhtml/files/CMakeLists.txt
new file mode 100644
index 0000000..24e17b2
--- /dev/null
+++ b/kde-misc/scriptedhtml/files/CMakeLists.txt
@@ -0,0 +1,11 @@
+project(scriptedhtml)
+
+find_package(KDE4 REQUIRED)
+
+include(KDE4Defaults)
+
+install(DIRECTORY scriptedimage/
+ DESTINATION ${DATA_INSTALL_DIR}/plasma/plasmoids/scriptedimage)
+
+install(FILES scriptedimage/metadata.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR} RENAME plasma-applet-scriptedhtml.desktop)
diff --git a/kde-misc/scriptedhtml/scriptedhtml-9999.ebuild b/kde-misc/scriptedhtml/scriptedhtml-9999.ebuild
new file mode 100644
index 0000000..a555464
--- /dev/null
+++ b/kde-misc/scriptedhtml/scriptedhtml-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit kde4-base git-r3
+
+DESCRIPTION="KDE plasmoid to display the output of script or URL"
+HOMEPAGE="http://kde-look.org/content/show.php?content=102052"
+EGIT_REPO_URI="https://github.com/lmiphay/pdamsten-plasmoids.git"
+
+LICENSE="GPL"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="
+ $(add_kdebase_dep plasma-workspace)
+"
+RDEPEND="${DEPEND}
+"
+
+src_prepare() {
+ cp -p ${FILESDIR}/CMakeLists.txt ${S}
+ kde4-base_src_prepare
+}