summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Kuhn <Wuodan0@gmail.com>2014-12-25 15:18:18 +0100
committerStefan Kuhn <Wuodan0@gmail.com>2014-12-25 15:18:18 +0100
commitac83c29f57bb6bb702e7c641ffc6aaf686449ec7 (patch)
tree9de75ef6cd94d056371d6fd01266464a39dc46fe /www-plugins/lightning/lightning-9999.ebuild
parentapp-cdr/dumpet: Manifest fix (diff)
downloadwuodan-ac83c29f57bb6bb702e7c641ffc6aaf686449ec7.tar.gz
wuodan-ac83c29f57bb6bb702e7c641ffc6aaf686449ec7.tar.bz2
wuodan-ac83c29f57bb6bb702e7c641ffc6aaf686449ec7.zip
www-plugins plus eclass: added plugins moved from pentoo overlay
Diffstat (limited to 'www-plugins/lightning/lightning-9999.ebuild')
-rw-r--r--www-plugins/lightning/lightning-9999.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/www-plugins/lightning/lightning-9999.ebuild b/www-plugins/lightning/lightning-9999.ebuild
new file mode 100644
index 0000000..2dfa59d
--- /dev/null
+++ b/www-plugins/lightning/lightning-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit mozilla-addon
+
+MOZ_ADDON_ID=2313
+DESCRIPTION="Lightning calendar for Thunderbird"
+HOMEPAGE="http://www.mozilla.org/en-US/projects/calendar/"
+SRC_URI="http://addons.mozilla.org/downloads/latest/${MOZ_ADDON_ID}/platform:2/ -> ${P}.xpi"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+symlink_all_targets target_thunderbird target_thunderbird-bin"
+
+# symlink all possible target paths if this is set
+if use symlink_all_targets; then
+ MZA_TARGETS="thunderbird thunderbird-bin"
+else
+ use target_thunderbird && MZA_TARGETS+=" thunderbird"
+ use target_thunderbird-bin && MZA_TARGETS+=" thunderbird-bin"
+fi
+
+RDEPEND="
+ !symlink_all_targets? (
+ target_thunderbird? ( mail-client/thunderbird[-lightning] )
+ target_thunderbird-bin? ( mail-client/thunderbird-bin )
+ )
+ !mail-client/thunderbird[lightning]"
+
+pkg_postinst() {
+ ewarn "This ebuild installs the latest STABLE version !"
+ ewarn "It is used by the maintainer to check for new versions ..."
+}