aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2016-06-28 14:44:13 +0200
committerMarius Brehler <marbre@linux.sungazer.de>2016-06-28 14:44:13 +0200
commit1c3d17cb3dbd37342aaa2009c395050ca6e8dcb8 (patch)
tree23d58c1f59369a2f17bfec46284921bcfff48afd
parentsci-biology/jannovar: improve ebuild, still does not work (diff)
parentMerge pull request #641 from TheChymera/dipy (diff)
downloadsci-1c3d17cb.tar.gz
sci-1c3d17cb.tar.bz2
sci-1c3d17cb.zip
Merge remote-tracking branch 'github/master'
-rw-r--r--sci-biology/dipy/Manifest1
-rw-r--r--sci-biology/dipy/dipy-0.11.0.ebuild36
-rw-r--r--sci-biology/dipy/dipy-9999.ebuild37
-rw-r--r--sci-biology/dipy/metadata.xml21
4 files changed, 95 insertions, 0 deletions
diff --git a/sci-biology/dipy/Manifest b/sci-biology/dipy/Manifest
new file mode 100644
index 000000000..1c13b2538
--- /dev/null
+++ b/sci-biology/dipy/Manifest
@@ -0,0 +1 @@
+DIST dipy-0.11.0.tar.gz 4943339 SHA256 b9b7c19ccf9d5087f2bdea86478319a5355bb4d4c5cb23afd7d85b09048d1716 SHA512 012c043f6c555d7abf0e67598a129b9538af6e9c3b613356ed7e015d866e85a165f8d1d3f79efa2f79bc0e101a908c42778bbdec0244f1fa122e1ff828f93cda WHIRLPOOL 9b5a24355fd8eccd168c7583dab725cc2d4a398f15f1fc1b3b7609f253d461286bf41f2e80d2c2adc85f20659169307e3523c4c2c4ceab94c94e7096bec7d358
diff --git a/sci-biology/dipy/dipy-0.11.0.ebuild b/sci-biology/dipy/dipy-0.11.0.ebuild
new file mode 100644
index 000000000..9c97079ce
--- /dev/null
+++ b/sci-biology/dipy/dipy-0.11.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="computational neuroanatomy project focusing on diffusion MRI"
+HOMEPAGE="http://nipy.org/dipy"
+SRC_URI="https://github.com/nipy/dipy/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ "
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ sci-libs/nibabel[${PYTHON_USEDEP}]
+ "
+
+python_test() {
+ distutils_install_for_testing
+ cd "${TEST_DIR}"/lib || die
+ nosetests || die
+}
+
diff --git a/sci-biology/dipy/dipy-9999.ebuild b/sci-biology/dipy/dipy-9999.ebuild
new file mode 100644
index 000000000..beb75e456
--- /dev/null
+++ b/sci-biology/dipy/dipy-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="computational neuroanatomy project focusing on diffusion MRI"
+HOMEPAGE="http://nipy.org/dipy"
+SRC_URI=""
+EGIT_REPO_URI="git://github.com/nipy/dipy"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+
+DEPEND="
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ "
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ sci-libs/nibabel[${PYTHON_USEDEP}]
+ "
+
+python_test() {
+ distutils_install_for_testing
+ cd "${TEST_DIR}"/lib || die
+ nosetests || die
+}
+
diff --git a/sci-biology/dipy/metadata.xml b/sci-biology/dipy/metadata.xml
new file mode 100644
index 000000000..80c312a7f
--- /dev/null
+++ b/sci-biology/dipy/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>h.chr@mail.ru</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Dipy is a free and open source software project for computational neuroanatomy, focusing mainly on
+ diffusion magnetic resonance imaging (dMRI) analysis. It implements a broad range of algorithms for
+ denoising, registration, reconstruction, tracking, clustering, visualization, and statistical
+ analysis of MRI data.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">nipy/dipy</remote-id>
+ </upstream>
+</pkgmetadata>