aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-30 10:50:12 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-30 10:50:12 +0100
commit375956ce96498b5a804ed970665ef96315d9efa4 (patch)
treecab6bfb280986b0db7974562b62151b37d7e3086
parentsci-libs/ciftilib: version bump, EAPI bump, cmake-utils-->cmake (diff)
downloadsci-375956ce.tar.gz
sci-375956ce.tar.bz2
sci-375956ce.zip
sci-libs/clfft: EAPI bump, add doc building
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
-rw-r--r--sci-libs/clfft/Manifest2
-rw-r--r--sci-libs/clfft/clfft-2.12.0.ebuild52
-rw-r--r--sci-libs/clfft/clfft-2.12.1.ebuild52
-rw-r--r--sci-libs/clfft/clfft-2.12.2.ebuild42
-rw-r--r--sci-libs/clfft/clfft-9999.ebuild40
5 files changed, 40 insertions, 148 deletions
diff --git a/sci-libs/clfft/Manifest b/sci-libs/clfft/Manifest
index 10f5aec57..1bba03d7f 100644
--- a/sci-libs/clfft/Manifest
+++ b/sci-libs/clfft/Manifest
@@ -1,3 +1 @@
-DIST clfft-2.12.0.tar.gz 1008780 BLAKE2B 0c5e311c041d8ab85853aca3a31c62db071e604c469e067efcb77d78caaf7a5f159141f2c8fd311b65cbeb6261b825fca996f8e1b1c830586e4781719b05dbad SHA512 8ee21847f2877989a1b6a62f62807e2cfd6d6845ed36702de775eb9dbccfed898e9969cce7bb93827745b5d65a5d91aaf07c565c92e65b6fefe3028efa9c23c9
-DIST clfft-2.12.1.tar.gz 1009856 BLAKE2B 6058eb61b9b50025c7da01b5ad1e24bf6d2306e010e72bc76af6216c6bc050fe169f48e865a83932230117398306a5b220c21539ae919d8e5c6f372973ea4960 SHA512 7eb5f1df45766d7ba80cf266264450e1dd733652a13e3fdb97109b7426515e04a96d887f11295f11fc9fe3fa43157652b65ec59a8c4a74a1dd384c47801b513f
DIST clfft-2.12.2.tar.gz 1010182 BLAKE2B 01e2b2a459ce39d87f5a6db89b8c7cad213a6c6918dc0fc2c0c7d99c61f635ce08ef51261c0c4e9d9000508d5a27b5d2ee7a665171d8f4f9e32a085be5f15b48 SHA512 19e9a4e06f76ae7c7808d1188677d5553c43598886a75328b7801ab2ca68e35206839a58fe2f958a44a6f7c83284dc9461cd0e21c37d1042bf82e24aad066be8
diff --git a/sci-libs/clfft/clfft-2.12.0.ebuild b/sci-libs/clfft/clfft-2.12.0.ebuild
deleted file mode 100644
index c008c602c..000000000
--- a/sci-libs/clfft/clfft-2.12.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-MY_PN="clFFT"
-
-DESCRIPTION="Library containing FFT functions written in OpenCL"
-HOMEPAGE="https://github.com/clMathLibraries/clFFT"
-SRC_URI="https://github.com/clMathLibraries/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="callback_client +client examples test"
-
-RDEPEND="
- >=sys-devel/gcc-4.6:*
- virtual/opencl
- dev-libs/boost"
-DEPEND="${RDEPEND}"
-# test? (
-# dev-cpp/gtest
-# sci-libs/fftw:3.0
-# )"
-
-# The tests only get compiled to an executable named Test, which is not recogniozed by cmake.
-# Therefore src_test() won't execute any test.
-RESTRICT="test"
-
-S="${WORKDIR}/${MY_PN}-${PV}/src"
-
-pkg_pretend() {
- if [[ ${MERGE_TYPE} != binary ]]; then
- if [[ $(gcc-major-version) -lt 4 ]] || ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 6 ]] ) ; then
- die "Compilation with gcc older than 4.6 is not supported."
- fi
- fi
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_CALLBACK_CLIENT="$(usex callback_client)"
- -DBUILD_CLIENT="$(usex client)"
- -DBUILD_SAMPLE="$(usex examples)"
- -DBUILD_TEST="$(usex test)"
- -DBoost_USE_STATIC_LIBS=OFF
- )
- cmake-utils_src_configure
-}
diff --git a/sci-libs/clfft/clfft-2.12.1.ebuild b/sci-libs/clfft/clfft-2.12.1.ebuild
deleted file mode 100644
index c008c602c..000000000
--- a/sci-libs/clfft/clfft-2.12.1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-MY_PN="clFFT"
-
-DESCRIPTION="Library containing FFT functions written in OpenCL"
-HOMEPAGE="https://github.com/clMathLibraries/clFFT"
-SRC_URI="https://github.com/clMathLibraries/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="callback_client +client examples test"
-
-RDEPEND="
- >=sys-devel/gcc-4.6:*
- virtual/opencl
- dev-libs/boost"
-DEPEND="${RDEPEND}"
-# test? (
-# dev-cpp/gtest
-# sci-libs/fftw:3.0
-# )"
-
-# The tests only get compiled to an executable named Test, which is not recogniozed by cmake.
-# Therefore src_test() won't execute any test.
-RESTRICT="test"
-
-S="${WORKDIR}/${MY_PN}-${PV}/src"
-
-pkg_pretend() {
- if [[ ${MERGE_TYPE} != binary ]]; then
- if [[ $(gcc-major-version) -lt 4 ]] || ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 6 ]] ) ; then
- die "Compilation with gcc older than 4.6 is not supported."
- fi
- fi
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_CALLBACK_CLIENT="$(usex callback_client)"
- -DBUILD_CLIENT="$(usex client)"
- -DBUILD_SAMPLE="$(usex examples)"
- -DBUILD_TEST="$(usex test)"
- -DBoost_USE_STATIC_LIBS=OFF
- )
- cmake-utils_src_configure
-}
diff --git a/sci-libs/clfft/clfft-2.12.2.ebuild b/sci-libs/clfft/clfft-2.12.2.ebuild
index c008c602c..9cfbc7f8a 100644
--- a/sci-libs/clfft/clfft-2.12.2.ebuild
+++ b/sci-libs/clfft/clfft-2.12.2.ebuild
@@ -1,12 +1,16 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-
-inherit cmake-utils
+EAPI=7
MY_PN="clFFT"
+DOCS_BUILDER="doxygen"
+DOCS_DIR="../docs"
+DOCS_CONFIG_NAME="${MY_PN}.doxy"
+
+inherit cmake docs
+
DESCRIPTION="Library containing FFT functions written in OpenCL"
HOMEPAGE="https://github.com/clMathLibraries/clFFT"
SRC_URI="https://github.com/clMathLibraries/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
@@ -14,17 +18,17 @@ SRC_URI="https://github.com/clMathLibraries/${MY_PN}/archive/v${PV}.tar.gz -> ${
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="callback_client +client examples test"
+IUSE="callback_client +client test"
RDEPEND="
- >=sys-devel/gcc-4.6:*
virtual/opencl
- dev-libs/boost"
+ dev-libs/boost
+"
DEPEND="${RDEPEND}"
-# test? (
-# dev-cpp/gtest
-# sci-libs/fftw:3.0
-# )"
+BDEPEND="test? (
+ dev-cpp/gtest
+ sci-libs/fftw:3.0
+)"
# The tests only get compiled to an executable named Test, which is not recogniozed by cmake.
# Therefore src_test() won't execute any test.
@@ -32,21 +36,17 @@ RESTRICT="test"
S="${WORKDIR}/${MY_PN}-${PV}/src"
-pkg_pretend() {
- if [[ ${MERGE_TYPE} != binary ]]; then
- if [[ $(gcc-major-version) -lt 4 ]] || ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 6 ]] ) ; then
- die "Compilation with gcc older than 4.6 is not supported."
- fi
- fi
-}
-
src_configure() {
local mycmakeargs=(
-DBUILD_CALLBACK_CLIENT="$(usex callback_client)"
-DBUILD_CLIENT="$(usex client)"
- -DBUILD_SAMPLE="$(usex examples)"
-DBUILD_TEST="$(usex test)"
-DBoost_USE_STATIC_LIBS=OFF
)
- cmake-utils_src_configure
+ cmake_src_configure
+}
+
+src_compile() {
+ docs_compile
+ cmake_src_compile
}
diff --git a/sci-libs/clfft/clfft-9999.ebuild b/sci-libs/clfft/clfft-9999.ebuild
index 55f39f28d..60e6861e0 100644
--- a/sci-libs/clfft/clfft-9999.ebuild
+++ b/sci-libs/clfft/clfft-9999.ebuild
@@ -1,34 +1,36 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-
-inherit cmake-utils git-r3
+EAPI=7
MY_PN="clFFT"
+DOCS_BUILDER="doxygen"
+DOCS_DIR="../docs"
+DOCS_CONFIG_NAME="${MY_PN}.doxy"
+
+inherit cmake docs git-r3
+
DESCRIPTION="Library containing FFT functions written in OpenCL"
HOMEPAGE="https://github.com/clMathLibraries/clFFT"
EGIT_REPO_URI="
https://github.com/clMathLibraries/${MY_PN}.git
git://github.com/clMathLibraries/${MY_PN}.git
- "
+"
EGIT_BRANCH="develop"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS=""
-IUSE="callback_client +client examples test"
+IUSE="callback_client +client test"
RDEPEND="
- >=sys-devel/gcc-4.6:*
virtual/opencl
dev-libs/boost"
DEPEND="${RDEPEND}"
-# test? (
-# dev-cpp/gtest
-# sci-libs/fftw:3.0
-# )"
+BDEPEND="test? (
+ dev-cpp/gtest
+ sci-libs/fftw:3.0
+)"
# The tests only get compiled to an executable named Test, which is not recogniozed by cmake.
# Therefore src_test() won't execute any test.
@@ -36,21 +38,17 @@ RESTRICT="test"
S="${WORKDIR}/${P}/src"
-pkg_pretend() {
- if [[ ${MERGE_TYPE} != binary ]]; then
- if [[ $(gcc-major-version) -lt 4 ]] || ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 6 ]] ) ; then
- die "Compilation with gcc older than 4.6 is not supported."
- fi
- fi
-}
-
src_configure() {
local mycmakeargs=(
-DBUILD_CALLBACK_CLIENT="$(usex callback_client)"
-DBUILD_CLIENT="$(usex client)"
- -DBUILD_SAMPLE="$(usex examples)"
-DBUILD_TEST="$(usex test)"
-DBoost_USE_STATIC_LIBS=OFF
)
cmake-utils_src_configure
}
+
+src_compile() {
+ docs_compile
+ cmake_src_compile
+}