summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2020-02-09 13:30:58 +0300
committerMichał Górny <mgorny@gentoo.org>2020-02-11 11:20:10 +0100
commit0e227570475e0b1becac7f986ac7f2a6b59a36ac (patch)
tree3427894759a1e76f08157d90ee239664c6702025
parentx11-terms/guake: Old (diff)
downloadgentoo-0e227570.tar.gz
gentoo-0e227570.tar.bz2
gentoo-0e227570.zip
app-doc/gimp-help: fix missing python_check_deps()
Closes: https://bugs.gentoo.org/708566 Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru> Closes: https://github.com/gentoo/gentoo/pull/14603 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-doc/gimp-help/gimp-help-2.10.0.ebuild6
-rw-r--r--app-doc/gimp-help/gimp-help-2.8.2.ebuild6
2 files changed, 10 insertions, 2 deletions
diff --git a/app-doc/gimp-help/gimp-help-2.10.0.ebuild b/app-doc/gimp-help/gimp-help-2.10.0.ebuild
index 7041b5998ba7..5180a87afe25 100644
--- a/app-doc/gimp-help/gimp-help-2.10.0.ebuild
+++ b/app-doc/gimp-help/gimp-help-2.10.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -23,6 +23,10 @@ DEPEND="$(python_gen_any_dep 'dev-libs/libxml2[python,${PYTHON_USEDEP}]')
dev-libs/libxslt
"
+python_check_deps() {
+ has_version "dev-libs/libxml2[${PYTHON_USEDEP}]"
+}
+
src_configure() {
econf --without-gimp
}
diff --git a/app-doc/gimp-help/gimp-help-2.8.2.ebuild b/app-doc/gimp-help/gimp-help-2.8.2.ebuild
index eddf386a020c..f1f2dea4b62c 100644
--- a/app-doc/gimp-help/gimp-help-2.8.2.ebuild
+++ b/app-doc/gimp-help/gimp-help-2.8.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -21,6 +21,10 @@ DEPEND="${PYTHON_DEPS}
sys-devel/gettext
"
+python_check_deps() {
+ has_version "dev-libs/libxml2[${PYTHON_USEDEP}]"
+}
+
src_configure() {
econf --without-gimp
}