summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-doc/gimp-help/gimp-help-2.10.0.ebuild6
-rw-r--r--app-doc/gimp-help/gimp-help-2.8.2.ebuild6
2 files changed, 10 insertions, 2 deletions
diff --git a/app-doc/gimp-help/gimp-help-2.10.0.ebuild b/app-doc/gimp-help/gimp-help-2.10.0.ebuild
index 7041b5998ba7..5180a87afe25 100644
--- a/app-doc/gimp-help/gimp-help-2.10.0.ebuild
+++ b/app-doc/gimp-help/gimp-help-2.10.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -23,6 +23,10 @@ DEPEND="$(python_gen_any_dep 'dev-libs/libxml2[python,${PYTHON_USEDEP}]')
dev-libs/libxslt
"
+python_check_deps() {
+ has_version "dev-libs/libxml2[${PYTHON_USEDEP}]"
+}
+
src_configure() {
econf --without-gimp
}
diff --git a/app-doc/gimp-help/gimp-help-2.8.2.ebuild b/app-doc/gimp-help/gimp-help-2.8.2.ebuild
index eddf386a020c..f1f2dea4b62c 100644
--- a/app-doc/gimp-help/gimp-help-2.8.2.ebuild
+++ b/app-doc/gimp-help/gimp-help-2.8.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -21,6 +21,10 @@ DEPEND="${PYTHON_DEPS}
sys-devel/gettext
"
+python_check_deps() {
+ has_version "dev-libs/libxml2[${PYTHON_USEDEP}]"
+}
+
src_configure() {
econf --without-gimp
}