summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-22 03:17:14 +0000
committerSam James <sam@gentoo.org>2022-01-22 03:20:48 +0000
commit0f71502657a78ba9336c1b1ce4c225e909ebffda (patch)
tree3e4a5fc460319fdfa54bf3416c88571303630b07
parentsys-auth/nss-pam-ldapd: 0.9.11 cleanup (diff)
downloadgentoo-0f71502657a78ba9336c1b1ce4c225e909ebffda.tar.gz
gentoo-0f71502657a78ba9336c1b1ce4c225e909ebffda.tar.bz2
gentoo-0f71502657a78ba9336c1b1ce4c225e909ebffda.zip
sys-boot/palo: add 2.15
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-boot/palo/Manifest1
-rw-r--r--sys-boot/palo/palo-2.15.ebuild50
-rw-r--r--sys-boot/palo/palo-9999.ebuild20
3 files changed, 64 insertions, 7 deletions
diff --git a/sys-boot/palo/Manifest b/sys-boot/palo/Manifest
index cc5d02da506f..8166e4ed1f4a 100644
--- a/sys-boot/palo/Manifest
+++ b/sys-boot/palo/Manifest
@@ -1 +1,2 @@
DIST palo-2.14.tar.gz 125207 BLAKE2B fcbc7e59552d83828c07acb055429c1155b738dd12e22c9fc81759b9f84382e3ea793e957421d420c93fa5818d5ad8f12b5317cfe6d5d45d95fc15b272c6fe8c SHA512 9d22ea2826a69a9bb661a4c17aaa78d648f0684b96c2dc0f164d2086f48fc85207e40c69227dd76d153dd171574dd62f6e5e90dd415209de372b4d7d8ab40f57
+DIST palo-2.15.tar.gz 126696 BLAKE2B 38e9defd248fc3e1f9bd921097e0888695a6a815a4221f4b030f225712f206b722232d05f5070b7a76763c50f8a623bb1a3f41c5c84a3999318f3a098d665b14 SHA512 bb46308988399028808d801317421da5a072a504e1c932513a80ee993653f45bd6cbb862c1b85c369506bca3c5d213bf8344ba263fae7ef13d8f73d9d3a6d412
diff --git a/sys-boot/palo/palo-2.15.ebuild b/sys-boot/palo/palo-2.15.ebuild
new file mode 100644
index 000000000000..5d425944019f
--- /dev/null
+++ b/sys-boot/palo/palo-2.15.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="PALO: PArisc Linux Loader"
+HOMEPAGE="https://parisc.wiki.kernel.org/"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://git.kernel.org/pub/scm/linux/kernel/git/deller/palo.git"
+ inherit git-r3
+else
+ SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/deller/${PN}.git/snapshot/${P}.tar.gz"
+ KEYWORDS="-* ~hppa"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~hppa"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.00-toolchain.patch
+)
+
+src_compile() {
+ local target
+ for target in '-C palo' '-C ipl' 'iplboot'; do
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)" LD="$(tc-getLD)" ${target}
+ done
+}
+
+src_install() {
+ into /
+ dosbin palo/palo
+
+ insinto /usr/share/palo
+ doins iplboot
+
+ insinto /etc
+ doins "${FILESDIR}"/palo.conf
+
+ insinto /etc/kernel/postinst.d
+ insopts -m 0744
+ doins "${FILESDIR}"/99palo
+
+ doman palo.8
+
+ dodoc TODO debian/changelog README.html
+}
diff --git a/sys-boot/palo/palo-9999.ebuild b/sys-boot/palo/palo-9999.ebuild
index 1c733273f096..2b80fbe60c6d 100644
--- a/sys-boot/palo/palo-9999.ebuild
+++ b/sys-boot/palo/palo-9999.ebuild
@@ -1,16 +1,22 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit git-r3 toolchain-funcs
-DESCRIPTION="PALO : PArisc Linux Loader"
-HOMEPAGE="http://parisc-linux.org/ https://parisc.wiki.kernel.org/"
-EGIT_REPO_URI="https://git.kernel.org/pub/scm/linux/kernel/git/deller/palo.git"
+inherit toolchain-funcs
+
+DESCRIPTION="PALO: PArisc Linux Loader"
+HOMEPAGE="https://parisc.wiki.kernel.org/"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://git.kernel.org/pub/scm/linux/kernel/git/deller/palo.git"
+ inherit git-r3
+else
+ SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/deller/${PN}.git/snapshot/${P}.tar.gz"
+ KEYWORDS="-* ~hppa"
+fi
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
PATCHES=(
"${FILESDIR}"/${PN}-2.00-toolchain.patch
@@ -19,7 +25,7 @@ PATCHES=(
src_compile() {
local target
for target in '-C palo' '-C ipl' 'iplboot'; do
- emake AR=$(tc-getAR) CC=$(tc-getCC) LD=$(tc-getLD) ${target}
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)" LD="$(tc-getLD)" ${target}
done
}