summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-01 19:23:52 +0000
committerSam James <sam@gentoo.org>2021-02-01 22:14:04 +0000
commit531a61e9d885c091ea7ab0596f9367e2f40a15af (patch)
treee222b7b430bb5190393506412407f0cda419c9b7
parentsys-power/uhubctl: bump to v2.3.0 (diff)
downloadgentoo-531a61e9.tar.gz
gentoo-531a61e9.tar.bz2
gentoo-531a61e9.zip
media-gfx/pngcheck: (security) bump to 3.0.2
Bug: https://bugs.gentoo.org/759013 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-gfx/pngcheck/Manifest1
-rw-r--r--media-gfx/pngcheck/pngcheck-3.0.2.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/media-gfx/pngcheck/Manifest b/media-gfx/pngcheck/Manifest
index f7d74b0cfa77..66af13d7895f 100644
--- a/media-gfx/pngcheck/Manifest
+++ b/media-gfx/pngcheck/Manifest
@@ -1 +1,2 @@
DIST pngcheck-2.3.0.tar.gz 59864 BLAKE2B 3c635555f76d22d6949309707b7054608f5e093d3a557eb88eb9fc48aef76326f8e6b0dbcdf8e30213a042416f0e6f798e41411763e7604b12495b6b2748cddc SHA512 d099a360d41fc553e9ea02e56ae9812a4a72f3b7f1cd73c021fdb0b9233bb247e100b95fe8e297a2dcdd1bb996128a365794cb8f5702e5c93618af03f18140ad
+DIST pngcheck-3.0.2.tar.gz 63202 BLAKE2B 4cc6040e087aa2f5829e79ea1a5feb45af8bb15fa72325f9cb4822169c7d278306d6d89b936fd4c3c3819a09380e07f1f64ce0c276e776c3146c1533b1ee1363 SHA512 81bba699141c0f506ee589785eccc4b1ea882df5d211bcd91885bbcc4230bf14d23fc1298ffc10a110d6a8459522f6a01bfba1f81739f6085e4d3de964bda3d5
diff --git a/media-gfx/pngcheck/pngcheck-3.0.2.ebuild b/media-gfx/pngcheck/pngcheck-3.0.2.ebuild
new file mode 100644
index 000000000000..ad45b82c58e8
--- /dev/null
+++ b/media-gfx/pngcheck/pngcheck-3.0.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Verifies the integrity of PNG, JNG and MNG files with internal checksums"
+HOMEPAGE="http://www.libpng.org/pub/png/apps/pngcheck.html"
+SRC_URI="mirror://sourceforge/png-mng/${P}.tar.gz"
+
+LICENSE="HPND GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake -f Makefile.unx \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getLD)" \
+ CFLAGS="${CFLAGS} ${LDFLAGS} -DUSE_ZLIB" \
+ ZLIB="-lz"
+}
+
+src_install() {
+ dobin png{check,split,-fix-IDAT-windowsize}
+ doman pngcheck.1 gpl/pngsplit.1
+
+ einstalldocs
+}