summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2024-01-30 14:45:38 +0200
committerSam James <sam@gentoo.org>2024-01-30 13:48:34 +0000
commit59a3a277d2adecbbfda0c88adf31583fd0cf99eb (patch)
tree66da5104f79c20aca0a46482f028662176a5cade
parentdev-libs/libxslt: drop --with-mem-debug with USE=debug (diff)
downloadgentoo-59a3a277d2adecbbfda0c88adf31583fd0cf99eb.tar.gz
gentoo-59a3a277d2adecbbfda0c88adf31583fd0cf99eb.tar.bz2
gentoo-59a3a277d2adecbbfda0c88adf31583fd0cf99eb.zip
gui-wm/wayfire: remove debug use flag
[sam: It's not appropriate to have a USE flag just for compiler flags, plus asan/ubsan/valgrind aren't appropriate in ebuilds either as they're so sensitive to e.g. sandbox.] Closes: https://bugs.gentoo.org/923333 Signed-off-by: Alfred Wingate <parona@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/35092 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--gui-wm/wayfire/wayfire-0.7.5-r1.ebuild11
-rw-r--r--gui-wm/wayfire/wayfire-0.8.0-r1.ebuild9
-rw-r--r--gui-wm/wayfire/wayfire-0.8.0.ebuild9
-rw-r--r--gui-wm/wayfire/wayfire-9999.ebuild11
4 files changed, 10 insertions, 30 deletions
diff --git a/gui-wm/wayfire/wayfire-0.7.5-r1.ebuild b/gui-wm/wayfire/wayfire-0.7.5-r1.ebuild
index d2d80d37344a..eed7d341eeca 100644
--- a/gui-wm/wayfire/wayfire-0.7.5-r1.ebuild
+++ b/gui-wm/wayfire/wayfire-0.7.5-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2019-2023 Gentoo Authors
+# Copyright 2019-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit meson toolchain-funcs
+inherit meson
DESCRIPTION="compiz like 3D wayland compositor"
HOMEPAGE="https://github.com/WayfireWM/wayfire"
@@ -18,7 +18,7 @@ fi
LICENSE="MIT"
SLOT="0"
-IUSE="debug +gles +system-wfconfig +system-wlroots X"
+IUSE="+gles +system-wfconfig +system-wlroots X"
DEPEND="
dev-libs/libinput:=
@@ -87,13 +87,8 @@ src_configure() {
$(meson_feature system-wlroots use_system_wlroots)
$(meson_feature X xwayland)
$(meson_use gles enable_gles32)
- $(usex debug --buildtype=debug "")
- $(usex debug -Db_sanitize=address,undefined "")
)
- # Clang will fail to link without this
- tc-is-clang && emesonargs+=( $(usex debug -Db_lundef=false "") )
-
meson_src_configure
}
diff --git a/gui-wm/wayfire/wayfire-0.8.0-r1.ebuild b/gui-wm/wayfire/wayfire-0.8.0-r1.ebuild
index 1fb2416c2bd8..21f177deca0c 100644
--- a/gui-wm/wayfire/wayfire-0.8.0-r1.ebuild
+++ b/gui-wm/wayfire/wayfire-0.8.0-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit meson toolchain-funcs
+inherit meson
DESCRIPTION="compiz like 3D wayland compositor"
HOMEPAGE="https://github.com/WayfireWM/wayfire"
@@ -19,7 +19,7 @@ else
fi
LICENSE="MIT"
-IUSE="debug +gles +system-wfconfig +system-wlroots test X"
+IUSE="+gles +system-wfconfig +system-wlroots test X"
RESTRICT="!test? ( test )"
# bundled wlroots has the following dependency string according to included headers.
@@ -128,13 +128,8 @@ src_configure() {
$(meson_feature test tests)
$(meson_feature X xwayland)
$(meson_use gles enable_gles32)
- $(usex debug --buildtype=debug "")
- $(usex debug -Db_sanitize=address,undefined "")
)
- # Clang will fail to link without this
- tc-is-clang && emesonargs+=( $(usex debug -Db_lundef=false "") )
-
meson_src_configure
}
diff --git a/gui-wm/wayfire/wayfire-0.8.0.ebuild b/gui-wm/wayfire/wayfire-0.8.0.ebuild
index 82a5b045146c..15e5598edc0f 100644
--- a/gui-wm/wayfire/wayfire-0.8.0.ebuild
+++ b/gui-wm/wayfire/wayfire-0.8.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit meson toolchain-funcs
+inherit meson
DESCRIPTION="compiz like 3D wayland compositor"
HOMEPAGE="https://github.com/WayfireWM/wayfire"
@@ -19,7 +19,7 @@ else
fi
LICENSE="MIT"
-IUSE="debug +gles +system-wfconfig +system-wlroots test X"
+IUSE="+gles +system-wfconfig +system-wlroots test X"
RESTRICT="!test? ( test )"
# bundled wlroots has the following dependency string according to included headers.
@@ -124,13 +124,8 @@ src_configure() {
$(meson_feature test tests)
$(meson_feature X xwayland)
$(meson_use gles enable_gles32)
- $(usex debug --buildtype=debug "")
- $(usex debug -Db_sanitize=address,undefined "")
)
- # Clang will fail to link without this
- tc-is-clang && emesonargs+=( $(usex debug -Db_lundef=false "") )
-
meson_src_configure
}
diff --git a/gui-wm/wayfire/wayfire-9999.ebuild b/gui-wm/wayfire/wayfire-9999.ebuild
index 98fb0ebc32f0..d1cadbe72df8 100644
--- a/gui-wm/wayfire/wayfire-9999.ebuild
+++ b/gui-wm/wayfire/wayfire-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2019-2023 Gentoo Authors
+# Copyright 2019-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit meson toolchain-funcs
+inherit meson
DESCRIPTION="compiz like 3D wayland compositor"
HOMEPAGE="https://github.com/WayfireWM/wayfire"
@@ -19,7 +19,7 @@ else
fi
LICENSE="MIT"
-IUSE="debug +gles +system-wfconfig +system-wlroots test X"
+IUSE="+gles +system-wfconfig +system-wlroots test X"
RESTRICT="!test? ( test )"
# bundled wlroots has the following dependency string according to included headers.
@@ -125,13 +125,8 @@ src_configure() {
$(meson_feature test tests)
$(meson_feature X xwayland)
$(meson_use gles enable_gles32)
- $(usex debug --buildtype=debug "")
- $(usex debug -Db_sanitize=address,undefined "")
)
- # Clang will fail to link without this
- tc-is-clang && emesonargs+=( $(usex debug -Db_lundef=false "") )
-
meson_src_configure
}