summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-01-06 07:47:24 +0000
committerSam James <sam@gentoo.org>2024-01-06 07:51:39 +0000
commitd99a19043e4cfe3270c7bf91ada6554d9d0382c4 (patch)
tree28d9ddfd25242beb27a7734089c95f5fa11b153e
parentsys-devel/llvm: fixup zlib, zstd handling (diff)
downloadgentoo-d99a19043e4cfe3270c7bf91ada6554d9d0382c4.tar.gz
gentoo-d99a19043e4cfe3270c7bf91ada6554d9d0382c4.tar.bz2
gentoo-d99a19043e4cfe3270c7bf91ada6554d9d0382c4.zip
sys-devel/lld: ixup zlib, zstd handling
From the LLVM docs: ``` LLVM_ENABLE_ZLIB:STRING Used to decide if LLVM tools should support compression/decompression with zlib. Allowed values are OFF, ON (default, enable if zlib is found), and FORCE_ON (error if zlib is not found). LLVM_ENABLE_ZSTD:STRING Used to decide if LLVM tools should support compression/decompression with zstd. Allowed values are OFF, ON (default, enable if zstd is found), and FORCE_ON (error if zstd is not found). ``` We had a user report that they had an LLVM / LLD built without zlib support despite the unconditional RDEPEND we have. Use FORCE_ON so we bail out at configure/build time rather than silently buliding without it if the system's zlib is broken. Ditto zstd. Bug: https://bugs.gentoo.org/873526 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-devel/lld/lld-15.0.7.ebuild3
-rw-r--r--sys-devel/lld/lld-16.0.6.ebuild4
-rw-r--r--sys-devel/lld/lld-17.0.6.ebuild4
-rw-r--r--sys-devel/lld/lld-18.0.0.9999.ebuild4
-rw-r--r--sys-devel/lld/lld-18.0.0_pre20231215.ebuild4
-rw-r--r--sys-devel/lld/lld-18.0.0_pre20231222.ebuild4
-rw-r--r--sys-devel/lld/lld-18.0.0_pre20231228.ebuild4
7 files changed, 20 insertions, 7 deletions
diff --git a/sys-devel/lld/lld-15.0.7.ebuild b/sys-devel/lld/lld-15.0.7.ebuild
index 9f1faebcbbbf..51a6a5bb778c 100644
--- a/sys-devel/lld/lld-15.0.7.ebuild
+++ b/sys-devel/lld/lld-15.0.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -69,6 +69,7 @@ src_configure() {
-DBUILD_SHARED_LIBS=ON
-DLLVM_INCLUDE_TESTS=$(usex test)
-DLLVM_MAIN_SRC_DIR="${WORKDIR}/llvm"
+ -DLLVM_ENABLE_ZLIB=FORCE_ON
)
use test && mycmakeargs+=(
diff --git a/sys-devel/lld/lld-16.0.6.ebuild b/sys-devel/lld/lld-16.0.6.ebuild
index 274f0ff243dd..ab2cbc982c7f 100644
--- a/sys-devel/lld/lld-16.0.6.ebuild
+++ b/sys-devel/lld/lld-16.0.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -70,6 +70,8 @@ src_configure() {
-DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr/lib/llvm/${LLVM_MAJOR}"
-DBUILD_SHARED_LIBS=ON
-DLLVM_INCLUDE_TESTS=$(usex test)
+ -DLLVM_ENABLE_ZLIB=FORCE_ON
+ -DLLVM_ENABLE_ZSTD=$(usex zstd FORCE_ON OFF)
)
use test && mycmakeargs+=(
diff --git a/sys-devel/lld/lld-17.0.6.ebuild b/sys-devel/lld/lld-17.0.6.ebuild
index 7289e547c49a..a6c8e30c0d8c 100644
--- a/sys-devel/lld/lld-17.0.6.ebuild
+++ b/sys-devel/lld/lld-17.0.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -68,6 +68,8 @@ src_configure() {
-DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr/lib/llvm/${LLVM_MAJOR}"
-DBUILD_SHARED_LIBS=ON
-DLLVM_INCLUDE_TESTS=$(usex test)
+ -DLLVM_ENABLE_ZLIB=FORCE_ON
+ -DLLVM_ENABLE_ZSTD=$(usex zstd FORCE_ON OFF)
)
use test && mycmakeargs+=(
diff --git a/sys-devel/lld/lld-18.0.0.9999.ebuild b/sys-devel/lld/lld-18.0.0.9999.ebuild
index c99759356a66..3dd9c8c26a2e 100644
--- a/sys-devel/lld/lld-18.0.0.9999.ebuild
+++ b/sys-devel/lld/lld-18.0.0.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -67,6 +67,8 @@ src_configure() {
-DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr/lib/llvm/${LLVM_MAJOR}"
-DBUILD_SHARED_LIBS=ON
-DLLVM_INCLUDE_TESTS=$(usex test)
+ -DLLVM_ENABLE_ZLIB=FORCE_ON
+ -DLLVM_ENABLE_ZSTD=$(usex zstd FORCE_ON OFF)
)
use test && mycmakeargs+=(
diff --git a/sys-devel/lld/lld-18.0.0_pre20231215.ebuild b/sys-devel/lld/lld-18.0.0_pre20231215.ebuild
index c99759356a66..3dd9c8c26a2e 100644
--- a/sys-devel/lld/lld-18.0.0_pre20231215.ebuild
+++ b/sys-devel/lld/lld-18.0.0_pre20231215.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -67,6 +67,8 @@ src_configure() {
-DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr/lib/llvm/${LLVM_MAJOR}"
-DBUILD_SHARED_LIBS=ON
-DLLVM_INCLUDE_TESTS=$(usex test)
+ -DLLVM_ENABLE_ZLIB=FORCE_ON
+ -DLLVM_ENABLE_ZSTD=$(usex zstd FORCE_ON OFF)
)
use test && mycmakeargs+=(
diff --git a/sys-devel/lld/lld-18.0.0_pre20231222.ebuild b/sys-devel/lld/lld-18.0.0_pre20231222.ebuild
index c99759356a66..3dd9c8c26a2e 100644
--- a/sys-devel/lld/lld-18.0.0_pre20231222.ebuild
+++ b/sys-devel/lld/lld-18.0.0_pre20231222.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -67,6 +67,8 @@ src_configure() {
-DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr/lib/llvm/${LLVM_MAJOR}"
-DBUILD_SHARED_LIBS=ON
-DLLVM_INCLUDE_TESTS=$(usex test)
+ -DLLVM_ENABLE_ZLIB=FORCE_ON
+ -DLLVM_ENABLE_ZSTD=$(usex zstd FORCE_ON OFF)
)
use test && mycmakeargs+=(
diff --git a/sys-devel/lld/lld-18.0.0_pre20231228.ebuild b/sys-devel/lld/lld-18.0.0_pre20231228.ebuild
index c99759356a66..3dd9c8c26a2e 100644
--- a/sys-devel/lld/lld-18.0.0_pre20231228.ebuild
+++ b/sys-devel/lld/lld-18.0.0_pre20231228.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -67,6 +67,8 @@ src_configure() {
-DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr/lib/llvm/${LLVM_MAJOR}"
-DBUILD_SHARED_LIBS=ON
-DLLVM_INCLUDE_TESTS=$(usex test)
+ -DLLVM_ENABLE_ZLIB=FORCE_ON
+ -DLLVM_ENABLE_ZSTD=$(usex zstd FORCE_ON OFF)
)
use test && mycmakeargs+=(