summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTed Tanberry <ted.tanberry@gmail.com>2015-10-10 21:04:45 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-14 14:47:58 +0200
commitddbfba3594bda0b32f359e057555d477ffbced1e (patch)
treeea878cf553eda9db8df5ca4d710fd83d4ef22f54
parentx11-libs/gdk-pixbuf: run glibc-specific test only on glibc (diff)
downloadgentoo-ddbfba3594bda0b32f359e057555d477ffbced1e.tar.gz
gentoo-ddbfba3594bda0b32f359e057555d477ffbced1e.tar.bz2
gentoo-ddbfba3594bda0b32f359e057555d477ffbced1e.zip
sci-biology/bowtie: version bump, SLOT major version
sci-biology/bowtie is now SLOTed, in order to allow for a parallel installation with bowtie2. In addition, the latest bowtie now supports dev-cpp/tbb with 'tbb' USE flag.
-rw-r--r--sci-biology/bowtie/Manifest4
-rw-r--r--sci-biology/bowtie/bowtie-0.12.8.ebuild44
-rw-r--r--sci-biology/bowtie/bowtie-1.0.0.ebuild42
-rw-r--r--sci-biology/bowtie/bowtie-1.1.2.ebuild58
-rw-r--r--sci-biology/bowtie/files/bowtie-0.12.8-gcc-47.patch45
-rw-r--r--sci-biology/bowtie/files/bowtie-1.1.2-tbb-tinythread-missing.patch14
-rw-r--r--sci-biology/bowtie/metadata.xml5
7 files changed, 79 insertions, 133 deletions
diff --git a/sci-biology/bowtie/Manifest b/sci-biology/bowtie/Manifest
index 1345a9e07e4e..1291400cabae 100644
--- a/sci-biology/bowtie/Manifest
+++ b/sci-biology/bowtie/Manifest
@@ -1,2 +1,2 @@
-DIST bowtie-0.12.8-src.zip 15569919 SHA256 f074a0f25e156976c4951fd69651d60caab925af9829054d107ec8b19af3082d SHA512 824eddd7db24177f7e15b90fb93a0426c2b8cee4dbcac2707f4cc7e7e42bafcad3775382b79d9b4d679e0c4b5c17a1b79ad134e91a968037336b34c6262e9c48 WHIRLPOOL 7056444822e7a0de619dcab933a7870ebe7db52008f3dbb2dd72aa189325d7ca4c353133d77150ec67c414e005a834458538f57746b13fd20f06bc7289869800
-DIST bowtie-1.0.0-src.zip 7710572 SHA256 51e434a78e053301f82ae56f4e94f71f97b19f7175324777a7305c8f88c5bac5 SHA512 d867a61c9d4caa2fbe8161b93acc9ccf04294055796a82ccf8d6456019e97299d90d9f16492f873606ae394bbc735108fc97ddf4e5d576a7376f3f9744118831 WHIRLPOOL a70d6516db8ee0c8838795e3b1df0ae1986342cee5dcafd80a39b06cb07ece79d7ebfc6e88b36625d9b33f4f42f559364f42dd4d881fd729c27eac9e673951a1
+DIST bowtie-1.1.2-src.zip 7713258 SHA256 b1e9ccc825207efd1893d9e33244c681bcb89b9b2b811eb95a9f5a92eab637ae SHA512 3d3d69bc3a865bb577b5a91440215d0d5b606c7a8751d565e606e36adbfbdef695b1718ae81cd3e2682a39ca7784c4d00976441e7618264ad99b04c7f53c36e8 WHIRLPOOL 08cb824bf7a1ddfbe6692de67191aacf44776d7d4e0ab66bd2a13ecfffd087bc28cdde4c7285c781fa4759de0a239e68f87b702bcc2e24c9b81fda5804360ce7
+DIST bowtie2-2.2.6-source.zip 5728779 SHA256 1000e90cdd90c3ca43c69d0d0ad951e190d36a6981a546f430a90ce86d64bfc8 SHA512 3ab5a5475cf214affd91e0d1782fd2d6dedccd979e3c809b5dfb272726d99ff1c7b59d92e387b187a7c2e43557786a1085186ccb96588de91212caf2eb94ce4f WHIRLPOOL 4fb02b3a0d76bbee0fe9abf91a71405922568bc38e593d5740df6279bad6f8b668df0debb0a81f3d3c23623558f34d842dd662a6838cf2d7f0fc8945fd00a298
diff --git a/sci-biology/bowtie/bowtie-0.12.8.ebuild b/sci-biology/bowtie/bowtie-0.12.8.ebuild
deleted file mode 100644
index c26c986ed194..000000000000
--- a/sci-biology/bowtie/bowtie-0.12.8.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=4
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="An ultrafast memory-efficient short read aligner"
-HOMEPAGE="http://bowtie-bio.sourceforge.net/"
-SRC_URI="mirror://sourceforge/bowtie-bio/${P}-src.zip"
-
-LICENSE="Artistic"
-SLOT="0"
-IUSE=""
-KEYWORDS="amd64 x86 ~x64-macos"
-
-DEPEND="app-arch/unzip"
-RDEPEND=""
-
-# NB: Bundles code from Maq (http://maq.sf.net) and the SeqAn library (http://www.seqan.de)
-# TODO: properly report system CFLAGS in -DCOMPILE_OPTIONS
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-gcc-47.patch
-}
-
-src_compile() {
- unset CFLAGS
- emake \
- CC="$(tc-getCC)" \
- CPP="$(tc-getCXX)" \
- CXX="$(tc-getCXX)" \
- EXTRA_FLAGS="${LDFLAGS}" \
- RELEASE_FLAGS=""
-}
-
-src_install() {
- dobin bowtie bowtie-*
- exeinto /usr/share/${PN}/scripts
- doexe scripts/*
- newman MANUAL bowtie.1
- dodoc AUTHORS NEWS TUTORIAL
-}
diff --git a/sci-biology/bowtie/bowtie-1.0.0.ebuild b/sci-biology/bowtie/bowtie-1.0.0.ebuild
deleted file mode 100644
index b8181190243c..000000000000
--- a/sci-biology/bowtie/bowtie-1.0.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="An ultrafast memory-efficient short read aligner"
-HOMEPAGE="http://bowtie-bio.sourceforge.net/"
-SRC_URI="mirror://sourceforge/bowtie-bio/${P}-src.zip"
-
-LICENSE="Artistic"
-SLOT="0"
-IUSE=""
-KEYWORDS="~amd64 ~x86 ~x64-macos"
-
-DEPEND="app-arch/unzip"
-RDEPEND=""
-
-src_compile() {
- unset CFLAGS
- emake \
- CC="$(tc-getCC)" \
- CPP="$(tc-getCXX)" \
- CXX="$(tc-getCXX)" \
- EXTRA_FLAGS="${LDFLAGS}" \
- RELEASE_FLAGS="${CXXFLAGS}"
-}
-
-src_install() {
- dobin bowtie bowtie-*
- exeinto /usr/share/${PN}/scripts
- doexe scripts/*
-
- insinto /usr/share/${PN}
- doins -r genomes indexes
-
- newman MANUAL bowtie.1
- dodoc AUTHORS NEWS TUTORIAL doc/README
- dohtml doc/{manual.html,style.css}
-}
diff --git a/sci-biology/bowtie/bowtie-1.1.2.ebuild b/sci-biology/bowtie/bowtie-1.1.2.ebuild
new file mode 100644
index 000000000000..55eec5060787
--- /dev/null
+++ b/sci-biology/bowtie/bowtie-1.1.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Popular short read aligner for Next-generation sequencing data"
+HOMEPAGE="http://bowtie-bio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bowtie-bio/${P}-src.zip"
+
+LICENSE="Artistic"
+SLOT="1"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+
+IUSE="examples tbb"
+
+DEPEND="app-arch/unzip
+ tbb? ( dev-cpp/tbb )"
+RDEPEND=""
+
+DOCS=( AUTHORS NEWS TUTORIAL doc/README )
+HTML_DOCS=( doc/{manual.html,style.css} )
+
+src_prepare() {
+ # Suppress useless -Wall pollution
+ sed -i 's/\-Wall/\-Wno-enum-compare/g' Makefile || die
+
+ # always include tinythread.cpp
+ epatch "${FILESDIR}/${P}-tbb-tinythread-missing.patch"
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CPP="$(tc-getCXX)" \
+ CFLAGS="" \
+ CXXFLAGS="" \
+ EXTRA_FLAGS="${LDFLAGS}" \
+ RELEASE_FLAGS="${CXXFLAGS}" \
+ WITH_TBB="$(usex tbb 1 0)"
+}
+
+src_install() {
+ dobin ${PN} ${PN}-*
+
+ exeinto /usr/libexec/${PN}
+ doexe scripts/*
+
+ newman MANUAL ${PN}.1
+ einstalldocs
+
+ if use examples; then
+ insinto /usr/share/${PN}
+ doins -r genomes indexes
+ fi
+}
diff --git a/sci-biology/bowtie/files/bowtie-0.12.8-gcc-47.patch b/sci-biology/bowtie/files/bowtie-0.12.8-gcc-47.patch
deleted file mode 100644
index 3c8a1e1d9ca4..000000000000
--- a/sci-biology/bowtie/files/bowtie-0.12.8-gcc-47.patch
+++ /dev/null
@@ -1,45 +0,0 @@
- alphabet.h | 24 ++++++++++++------------
- 1 files changed, 12 insertions(+), 12 deletions(-)
-
-diff --git a/alphabet.h b/alphabet.h
-index b464ddf..08d0281 100644
---- a/alphabet.h
-+++ b/alphabet.h
-@@ -38,6 +38,18 @@ static inline TStr reverseComplement(const TStr& s, bool color) {
- return s_rc;
- }
-
-+/// Reverse a string in-place
-+template <typename TStr>
-+static inline void reverseInPlace(TStr& s) {
-+ typedef typename Value<TStr>::Type TVal;
-+ size_t len = length(s);
-+ for(size_t i = 0; i < (len>>1); i++) {
-+ TVal tmp = s[i];
-+ s[i] = s[len-i-1];
-+ s[len-i-1] = tmp;
-+ }
-+}
-+
- /**
- * Reverse-complement s in-place. Ns go to Ns.
- */
-@@ -69,18 +81,6 @@ static inline void reverseComplementInPlace(TStr& s, bool color) {
- }
- }
-
--/// Reverse a string in-place
--template <typename TStr>
--static inline void reverseInPlace(TStr& s) {
-- typedef typename Value<TStr>::Type TVal;
-- size_t len = length(s);
-- for(size_t i = 0; i < (len>>1); i++) {
-- TVal tmp = s[i];
-- s[i] = s[len-i-1];
-- s[len-i-1] = tmp;
-- }
--}
--
- /**
- * Return the reverse-complement of s.
- */
diff --git a/sci-biology/bowtie/files/bowtie-1.1.2-tbb-tinythread-missing.patch b/sci-biology/bowtie/files/bowtie-1.1.2-tbb-tinythread-missing.patch
new file mode 100644
index 000000000000..2a081ff297b8
--- /dev/null
+++ b/sci-biology/bowtie/files/bowtie-1.1.2-tbb-tinythread-missing.patch
@@ -0,0 +1,14 @@
+--- bowtie-1.1.2/Makefile
++++ bowtie-1.1.2/Makefile
+@@ -106,10 +106,7 @@
+ endif
+
+ OTHER_CPPS = ccnt_lut.cpp ref_read.cpp alphabet.cpp shmem.cpp \
+- edit.cpp ebwt.cpp
+-ifneq (1,$(WITH_TBB))
+- OTHER_CPPS += tinythread.cpp
+-endif
++ edit.cpp ebwt.cpp tinythread.cpp
+
+ SEARCH_CPPS = qual.cpp pat.cpp ebwt_search_util.cpp ref_aligner.cpp \
+ log.cpp hit_set.cpp refmap.cpp annot.cpp sam.cpp \
diff --git a/sci-biology/bowtie/metadata.xml b/sci-biology/bowtie/metadata.xml
index e493417070fb..58f2d3652fa7 100644
--- a/sci-biology/bowtie/metadata.xml
+++ b/sci-biology/bowtie/metadata.xml
@@ -5,4 +5,9 @@
<upstream>
<remote-id type="sourceforge">bowtie-bio</remote-id>
</upstream>
+ <use>
+ <flag name='tbb'>Enables building bowtie with the Intel
+ Threading Building Blocks from <pkg>dev-cpp/tbb</pkg>. This
+ flag is recommended.</flag>
+ </use>
</pkgmetadata>