summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-02-12 23:17:39 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-02-12 23:18:12 +0100
commit5c2eb86b358dbc9047cbac088d7cfe805be04301 (patch)
treee1bbdd2d4e61ab4fc2fa96fb08a5b7e1bed04331 /app-arch/dtrx/dtrx-9999.ebuild
parentdev-python/networkx: Stabilize 3.0 ALLARCHES, #894100 (diff)
downloadgentoo-5c2eb86b358dbc9047cbac088d7cfe805be04301.tar.gz
gentoo-5c2eb86b358dbc9047cbac088d7cfe805be04301.tar.bz2
gentoo-5c2eb86b358dbc9047cbac088d7cfe805be04301.zip
app-arch/dtrx: new package; add 8.5.0 and live
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-arch/dtrx/dtrx-9999.ebuild')
-rw-r--r--app-arch/dtrx/dtrx-9999.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-arch/dtrx/dtrx-9999.ebuild b/app-arch/dtrx/dtrx-9999.ebuild
new file mode 100644
index 000000000000..03c4b8340d0c
--- /dev/null
+++ b/app-arch/dtrx/dtrx-9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Do The Right eXtraction - extracts archives of different formats"
+HOMEPAGE="https://github.com/dtrx-py/dtrx/
+ https://pypi.org/project/dtrx/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}-py/${PN}.git"
+else
+ SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( README.md )
+
+pkg_postinst() {
+ local supported_format
+ local -a supported_formats=(
+ arj
+ bzip2
+ cpio
+ gzip
+ lrzip
+ lzip
+ p7zip
+ rpm
+ unrar
+ unzip
+ xz-utils
+ zip
+ zstd
+ )
+
+ for supported_format in ${supported_formats[@]}; do
+ optfeature \
+ "extraction of supported archives using ${supported_format}" \
+ app-arch/${supported_format}
+ done
+}