summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2021-01-30 03:13:15 +0000
committerJoonas Niilola <juippis@gentoo.org>2021-02-10 15:36:00 +0200
commit5cbfdb87cda11c938e27db60ae7ebfb0b122786a (patch)
tree9f92c550f8bed67e9e2681c387d2cd0c78eff546 /gui-apps
parentgui-apps/wcm: version bump to 0.7.0 (diff)
downloadgentoo-5cbfdb87cda11c938e27db60ae7ebfb0b122786a.tar.gz
gentoo-5cbfdb87cda11c938e27db60ae7ebfb0b122786a.tar.bz2
gentoo-5cbfdb87cda11c938e27db60ae7ebfb0b122786a.zip
gui-apps/wf-shell: version bump to 0.7.0
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/wf-shell/Manifest1
-rw-r--r--gui-apps/wf-shell/wf-shell-0.7.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/gui-apps/wf-shell/Manifest b/gui-apps/wf-shell/Manifest
index 5af436f3cf28..f47c542ed58c 100644
--- a/gui-apps/wf-shell/Manifest
+++ b/gui-apps/wf-shell/Manifest
@@ -1,2 +1,3 @@
DIST wf-shell-0.5.0.tar.xz 8998296 BLAKE2B c32232fc08292b15a0048d11d0f179a82fd21b3179223d898057ac95b42ac35ec063467f67c0f1261857c3b643edc4367112a05bb63f002788b64ed86559addd SHA512 d0029746ea10625bb47381a7ed74aadb8aa3823f83f751b539eefd49da5aa1643a2d16c55fe23d30bd71528ad5c1ea8d389909fe8cc1026746b3b76aa5dabd2b
DIST wf-shell-0.6.1.tar.xz 9014596 BLAKE2B 5256ceb8dc2b3dd4cf5d4503595c46b72bcde1dd4804a5871e225cee5b028ac69b02618d9c348fca4e21f2fd81b2be51fb0122126dd200dcdaeac894ec902c21 SHA512 d710cf703f5671bba01d056c7733724f90e6510a50e45a1a30cacde33a689c065335d802a3fd556cf9f8f0f420266ed2a8616706ecf5a68dcdf45a79876a4bcf
+DIST wf-shell-0.7.0.tar.xz 9014840 BLAKE2B f2e1ffb76de79db580227ddefc10c9f3431c92f77e6519da1102e7c4456bb30c4f25c82570a5b2796985dac00be65f9428ac6682e80920ed22359f63e3e6a84d SHA512 3d72c5d399280ee9da841a417faf696f8baa40edc1040bc1f354f113a8e431dbab428c93928b1d3faa520e35211345cabb5c70f55e10cfb7a4c321a6db19df90
diff --git a/gui-apps/wf-shell/wf-shell-0.7.0.ebuild b/gui-apps/wf-shell/wf-shell-0.7.0.ebuild
new file mode 100644
index 000000000000..11f54e22daca
--- /dev/null
+++ b/gui-apps/wf-shell/wf-shell-0.7.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="A compiz like 3D wayland compositor"
+HOMEPAGE="https://github.com/WayfireWM/wf-shell"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/${PN}.git"
+else
+ SRC_URI="https://github.com/WayfireWM/${PN}/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+pulseaudio"
+
+DEPEND="
+ dev-cpp/gtkmm:3.0=[wayland]
+ dev-libs/gobject-introspection
+ gui-libs/gtk-layer-shell
+ >=gui-wm/wayfire-${PV%.*}
+ pulseaudio? ( media-sound/pulseaudio )
+"
+RDEPEND="${DEPEND}
+ gui-apps/wayland-logout
+"
+BDEPEND="
+ dev-libs/wayland-protocols
+ virtual/pkgconfig
+"
+
+src_configure () {
+ local emesonargs=(
+ "$(meson_feature pulseaudio pulse)"
+ -Dwayland-logout=false
+ )
+ meson_src_configure
+}