summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-06-30 09:45:36 +0200
committerMichał Górny <mgorny@gentoo.org>2019-06-30 09:52:43 +0200
commitb6aeb1cce5b8f6dd1c50f9c29852214da39a52d3 (patch)
tree077a5cdb33aae9cfddf2efa914a1de8a1d510c0f /media-libs
parentdev-lang/swig: remove old 2.0.12 (diff)
downloadgentoo-b6aeb1cce5b8f6dd1c50f9c29852214da39a52d3.tar.gz
gentoo-b6aeb1cce5b8f6dd1c50f9c29852214da39a52d3.tar.bz2
gentoo-b6aeb1cce5b8f6dd1c50f9c29852214da39a52d3.zip
media-libs/mesa: Add missing LLVM_SLOT in llvm_check_deps()
Reported-by: Tim Harder <radhermit@gentoo.org> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/mesa/mesa-18.3.6.ebuild4
-rw-r--r--media-libs/mesa/mesa-19.0.6.ebuild4
-rw-r--r--media-libs/mesa/mesa-19.0.7.ebuild4
-rw-r--r--media-libs/mesa/mesa-19.0.8.ebuild4
-rw-r--r--media-libs/mesa/mesa-19.1.0.ebuild4
-rw-r--r--media-libs/mesa/mesa-19.1.1.ebuild4
-rw-r--r--media-libs/mesa/mesa-9999.ebuild4
7 files changed, 14 insertions, 14 deletions
diff --git a/media-libs/mesa/mesa-18.3.6.ebuild b/media-libs/mesa/mesa-18.3.6.ebuild
index 307d5733e841..88a3f43e5c6e 100644
--- a/media-libs/mesa/mesa-18.3.6.ebuild
+++ b/media-libs/mesa/mesa-18.3.6.ebuild
@@ -238,9 +238,9 @@ llvm_check_deps() {
fi
if use opencl; then
- has_version "sys-devel/clang[${flags}]" || return 1
+ has_version "sys-devel/clang:${LLVM_SLOT}[${flags}]" || return 1
fi
- has_version "sys-devel/llvm[${flags}]"
+ has_version "sys-devel/llvm:${LLVM_SLOT}[${flags}]"
}
pkg_pretend() {
diff --git a/media-libs/mesa/mesa-19.0.6.ebuild b/media-libs/mesa/mesa-19.0.6.ebuild
index 6e5cc0499b8b..cb29e92acfb6 100644
--- a/media-libs/mesa/mesa-19.0.6.ebuild
+++ b/media-libs/mesa/mesa-19.0.6.ebuild
@@ -242,9 +242,9 @@ llvm_check_deps() {
fi
if use opencl; then
- has_version "sys-devel/clang[${flags}]" || return 1
+ has_version "sys-devel/clang:${LLVM_SLOT}[${flags}]" || return 1
fi
- has_version "sys-devel/llvm[${flags}]"
+ has_version "sys-devel/llvm:${LLVM_SLOT}[${flags}]"
}
pkg_pretend() {
diff --git a/media-libs/mesa/mesa-19.0.7.ebuild b/media-libs/mesa/mesa-19.0.7.ebuild
index 6e5cc0499b8b..cb29e92acfb6 100644
--- a/media-libs/mesa/mesa-19.0.7.ebuild
+++ b/media-libs/mesa/mesa-19.0.7.ebuild
@@ -242,9 +242,9 @@ llvm_check_deps() {
fi
if use opencl; then
- has_version "sys-devel/clang[${flags}]" || return 1
+ has_version "sys-devel/clang:${LLVM_SLOT}[${flags}]" || return 1
fi
- has_version "sys-devel/llvm[${flags}]"
+ has_version "sys-devel/llvm:${LLVM_SLOT}[${flags}]"
}
pkg_pretend() {
diff --git a/media-libs/mesa/mesa-19.0.8.ebuild b/media-libs/mesa/mesa-19.0.8.ebuild
index 6e5cc0499b8b..cb29e92acfb6 100644
--- a/media-libs/mesa/mesa-19.0.8.ebuild
+++ b/media-libs/mesa/mesa-19.0.8.ebuild
@@ -242,9 +242,9 @@ llvm_check_deps() {
fi
if use opencl; then
- has_version "sys-devel/clang[${flags}]" || return 1
+ has_version "sys-devel/clang:${LLVM_SLOT}[${flags}]" || return 1
fi
- has_version "sys-devel/llvm[${flags}]"
+ has_version "sys-devel/llvm:${LLVM_SLOT}[${flags}]"
}
pkg_pretend() {
diff --git a/media-libs/mesa/mesa-19.1.0.ebuild b/media-libs/mesa/mesa-19.1.0.ebuild
index 20146f77c705..dc0cc0f2e6d4 100644
--- a/media-libs/mesa/mesa-19.1.0.ebuild
+++ b/media-libs/mesa/mesa-19.1.0.ebuild
@@ -245,9 +245,9 @@ llvm_check_deps() {
fi
if use opencl; then
- has_version "sys-devel/clang[${flags}]" || return 1
+ has_version "sys-devel/clang:${LLVM_SLOT}[${flags}]" || return 1
fi
- has_version "sys-devel/llvm[${flags}]"
+ has_version "sys-devel/llvm:${LLVM_SLOT}[${flags}]"
}
pkg_pretend() {
diff --git a/media-libs/mesa/mesa-19.1.1.ebuild b/media-libs/mesa/mesa-19.1.1.ebuild
index d1efde2b6aa7..0fd4ae716a5f 100644
--- a/media-libs/mesa/mesa-19.1.1.ebuild
+++ b/media-libs/mesa/mesa-19.1.1.ebuild
@@ -247,9 +247,9 @@ llvm_check_deps() {
fi
if use opencl; then
- has_version "sys-devel/clang[${flags}]" || return 1
+ has_version "sys-devel/clang:${LLVM_SLOT}[${flags}]" || return 1
fi
- has_version "sys-devel/llvm[${flags}]"
+ has_version "sys-devel/llvm:${LLVM_SLOT}[${flags}]"
}
pkg_pretend() {
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index d1efde2b6aa7..0fd4ae716a5f 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -247,9 +247,9 @@ llvm_check_deps() {
fi
if use opencl; then
- has_version "sys-devel/clang[${flags}]" || return 1
+ has_version "sys-devel/clang:${LLVM_SLOT}[${flags}]" || return 1
fi
- has_version "sys-devel/llvm[${flags}]"
+ has_version "sys-devel/llvm:${LLVM_SLOT}[${flags}]"
}
pkg_pretend() {