summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-01-06 07:47:24 +0000
committerSam James <sam@gentoo.org>2024-01-06 07:51:39 +0000
commitd99a19043e4cfe3270c7bf91ada6554d9d0382c4 (patch)
tree28d9ddfd25242beb27a7734089c95f5fa11b153e /sys-devel/lld/lld-16.0.6.ebuild
parentsys-devel/llvm: fixup zlib, zstd handling (diff)
downloadgentoo-d99a19043e4cfe3270c7bf91ada6554d9d0382c4.tar.gz
gentoo-d99a19043e4cfe3270c7bf91ada6554d9d0382c4.tar.bz2
gentoo-d99a19043e4cfe3270c7bf91ada6554d9d0382c4.zip
sys-devel/lld: ixup zlib, zstd handling
From the LLVM docs: ``` LLVM_ENABLE_ZLIB:STRING Used to decide if LLVM tools should support compression/decompression with zlib. Allowed values are OFF, ON (default, enable if zlib is found), and FORCE_ON (error if zlib is not found). LLVM_ENABLE_ZSTD:STRING Used to decide if LLVM tools should support compression/decompression with zstd. Allowed values are OFF, ON (default, enable if zstd is found), and FORCE_ON (error if zstd is not found). ``` We had a user report that they had an LLVM / LLD built without zlib support despite the unconditional RDEPEND we have. Use FORCE_ON so we bail out at configure/build time rather than silently buliding without it if the system's zlib is broken. Ditto zstd. Bug: https://bugs.gentoo.org/873526 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel/lld/lld-16.0.6.ebuild')
-rw-r--r--sys-devel/lld/lld-16.0.6.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/sys-devel/lld/lld-16.0.6.ebuild b/sys-devel/lld/lld-16.0.6.ebuild
index 274f0ff243dd..ab2cbc982c7f 100644
--- a/sys-devel/lld/lld-16.0.6.ebuild
+++ b/sys-devel/lld/lld-16.0.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -70,6 +70,8 @@ src_configure() {
-DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr/lib/llvm/${LLVM_MAJOR}"
-DBUILD_SHARED_LIBS=ON
-DLLVM_INCLUDE_TESTS=$(usex test)
+ -DLLVM_ENABLE_ZLIB=FORCE_ON
+ -DLLVM_ENABLE_ZSTD=$(usex zstd FORCE_ON OFF)
)
use test && mycmakeargs+=(