summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/cscope/files')
-rw-r--r--dev-util/cscope/files/cscope-15.6-darwin.patch11
-rw-r--r--dev-util/cscope/files/cscope-15.9-emacs-27.patch28
-rw-r--r--dev-util/cscope/files/cscope-15.9-pkgconfig.patch28
3 files changed, 56 insertions, 11 deletions
diff --git a/dev-util/cscope/files/cscope-15.6-darwin.patch b/dev-util/cscope/files/cscope-15.6-darwin.patch
deleted file mode 100644
index e755f3257efd..000000000000
--- a/dev-util/cscope/files/cscope-15.6-darwin.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/constants.h
-+++ b/src/constants.h
-@@ -103,7 +103,7 @@
- #define INCLUDES 8
- #define FIELDS 9
-
--#if (BSD || V9) && !__NetBSD__ && !__FreeBSD__
-+#if (BSD || V9) && !__NetBSD__ && !__FreeBSD__ && !__MACH__
- # define TERMINFO 0 /* no terminfo curses */
- #else
- # define TERMINFO 1
diff --git a/dev-util/cscope/files/cscope-15.9-emacs-27.patch b/dev-util/cscope/files/cscope-15.9-emacs-27.patch
new file mode 100644
index 000000000000..48cd7150176d
--- /dev/null
+++ b/dev-util/cscope/files/cscope-15.9-emacs-27.patch
@@ -0,0 +1,28 @@
+https://bugs.gentoo.org/892071
+
+commit eaea31cb93ecddda69a373f83f632e1a450c3c90
+Author: Brock Zheng Techyauld Ltd <yzheng@techyauld.com>
+Date: Tue Aug 25 20:28:11 2020 +0800
+
+ emacs plugin fixup: GNU/Emacs 27.1 removes function process-kill-without-query
+
+--- a/contrib/xcscope/xcscope.el
++++ b/contrib/xcscope/xcscope.el
+@@ -2006,7 +2006,7 @@
+ (set-process-filter cscope-process cscope-filter-func)
+ (set-process-sentinel cscope-process cscope-sentinel-func)
+ (set-marker (process-mark cscope-process) (point))
+- (process-kill-without-query cscope-process)
++ (set-process-query-on-exit-flag cscope-process nil)
+ (if cscope-running-in-xemacs
+ (setq modeline-process ": Searching ..."))
+ (setq buffer-read-only t)
+@@ -2139,7 +2139,7 @@
+ cscope-indexing-script args))
+ (set-process-sentinel cscope-unix-index-process
+ 'cscope-unix-index-files-sentinel)
+- (process-kill-without-query cscope-unix-index-process)
++ (set-process-query-on-exit-flag cscope-unix-index-process nil)
+ )
+ ))
+
diff --git a/dev-util/cscope/files/cscope-15.9-pkgconfig.patch b/dev-util/cscope/files/cscope-15.9-pkgconfig.patch
new file mode 100644
index 000000000000..c031633a6559
--- /dev/null
+++ b/dev-util/cscope/files/cscope-15.9-pkgconfig.patch
@@ -0,0 +1,28 @@
+--- a/configure.in
++++ b/configure.in
+@@ -18,6 +18,7 @@ if test "x$LEX" = "xlex" ; then AC_DEFINE(USING_LEX, 1,
+ [Define this if the scanner is run through lex, not flex])
+ fi
+ AC_PROG_YACC
++PKG_PROG_PKG_CONFIG
+
+ AC_SYS_LARGEFILE
+
+@@ -361,7 +362,7 @@ dnl Check for a GNOME installation
+ AC_DEFUN([AC_CHECK_GNOME],[
+ has_gnome=false
+ AC_CHECK_PROG(gnome1, gnome-config, true)
+- AC_CHECK_PROG(gnome2, pkg-config, true)
++ AC_CHECK_PROG(gnome2, $PKG_CONFIG, true)
+
+ if test x$gnome1 = xtrue; then
+ has_gnome=true
+@@ -371,7 +372,7 @@ AC_DEFUN([AC_CHECK_GNOME],[
+ has_gnome=true
+ fi
+
+- AM_CONDITIONAL(USING_GNOME2, pkg-config --exists gtk+-2.0)
++ AM_CONDITIONAL(USING_GNOME2, $PKG_CONFIG --exists gtk+-2.0)
+ AM_CONDITIONAL(HAS_GNOME, test "$has_gnome" = true)
+ AM_CONDITIONAL(GNOME_LINUX, test "$host_os" = Linux)
+ ])