aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac.paragon@gmail.com>2022-03-02 09:57:46 +0200
committerViorel Munteanu <ceamac.paragon@gmail.com>2022-03-02 09:57:46 +0200
commit8289ba50192b11b73fe5e4ebbda7b1c181c33949 (patch)
tree1c5c03dee58c3a2a11eb3aa04994150138d846b9
parentdev-python/desktop-notifier: add 3.3.3 (diff)
downloadguru-8289ba50.tar.gz
guru-8289ba50.tar.bz2
guru-8289ba50.zip
dev-python/desktop-notifier: add 3.3.4
Signed-off-by: Viorel Munteanu <ceamac.paragon@gmail.com>
-rw-r--r--dev-python/desktop-notifier/Manifest1
-rw-r--r--dev-python/desktop-notifier/desktop-notifier-3.3.4.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/desktop-notifier/Manifest b/dev-python/desktop-notifier/Manifest
index 8cf57889d..d4fc18109 100644
--- a/dev-python/desktop-notifier/Manifest
+++ b/dev-python/desktop-notifier/Manifest
@@ -1,2 +1,3 @@
DIST desktop-notifier-3.3.2.tar.gz 4595234 BLAKE2B c53383b8f15c36acb21a77695b8a76e782f912078ba7c5946fe55c2e8c3c950ece7581a81a69dbee12553be7155364c9165336d7f2b814ccb0e3076dc082cf85 SHA512 d93825ea4880428e9eb41f0adff27e963ebeae23aa5cdc8c77e4a60aecee69aa1448f9aca8b12520597b52df531580e29e3458c2ea7b4f2e60eda68de5dfbe9f
DIST desktop-notifier-3.3.3.tar.gz 4595797 BLAKE2B e27f6927d67603d20ab3729ddbd436d75110a97cb82d3db80e4229c8e297803783f9b4f3212b284f83989778354600fc7efe553b20a66cc6ea3d8eccafc00466 SHA512 a0b9dbd50b53380712529636df949621a418f58f06ad97251b22f744f0dfbb47ef0d5697fc279fa49b085f653494dc6acc18a6531752b6a288831b9c05e4a241
+DIST desktop-notifier-3.3.4.tar.gz 4595239 BLAKE2B 6dc8ca771cffce06a4fe0f3e1dfeb66ee0a73a5ea4c4311405c1131ff3c9736492360d1666d365d8262afeffb72633804e1b7822ce8862111401789547ef5536 SHA512 4ae35f8b6a25fef99a755f599cb5eb724cf0c48e8c9c314bdb1fcb3e839ef89ca939c8a5f3c5a3a01b8f484a3da874ddb3547b4df3cdb126cb3c64c31418792a
diff --git a/dev-python/desktop-notifier/desktop-notifier-3.3.4.ebuild b/dev-python/desktop-notifier/desktop-notifier-3.3.4.ebuild
new file mode 100644
index 000000000..5ad16b998
--- /dev/null
+++ b/dev-python/desktop-notifier/desktop-notifier-3.3.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="desktop-notifier is a Python library for cross-platform desktop notifications"
+HOMEPAGE="
+ https://desktop-notifier.readthedocs.io
+ https://pypi.org/project/desktop-notifier
+ https://github.com/samschott/desktop-notifier
+"
+SRC_URI="https://github.com/samschott/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/wheel[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/python-dbus-next[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/importlib_resources[${PYTHON_USEDEP}]' python3_8)
+"
+
+distutils_enable_sphinx docs