summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* games-util/basis_universal: fix build w/ AVXSam James29 hours2-0/+41
| | | | | Closes: https://bugs.gentoo.org/892727 Signed-off-by: Sam James <sam@gentoo.org>
* games-util/antimicrox: Stabilize 3.3.1 amd64, #892673Sam James5 days1-2/+2
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* games-util/antimicrox: drop old 3.2.5Maciej Barć5 days2-75/+0
| | | | Signed-off-by: Maciej Barć <xgqt@gentoo.org>
* games-util/antimicrox: bump to 3.3.3Maciej Barć5 days2-0/+75
| | | | Signed-off-by: Maciej Barć <xgqt@gentoo.org>
* games-util/lutris: update 9999 ebuild in preparation of 0.5.13 releaseAndrew Ammerlaan8 days2-4/+31
| | | | Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
* games-util/basis_universal: Keyword 1.16.3 x86, #892329Arthur Zamarin8 days1-1/+1
| | | | Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
* games-util/basis_universal: new package, add 1.16.3Sam James8 days5-0/+79
| | | | | Bug: https://bugs.gentoo.org/879319 Signed-off-by: Sam James <sam@gentoo.org>
* */*: remove py3.8 from PYTHON_COMPATDavid Seifert2023-01-148-14/+14
| | | | Signed-off-by: David Seifert <soap@gentoo.org>
* games-util/nml: add 0.7.1Sam James2023-01-102-0/+36
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* games-util/nml: enable py3.11Sam James2023-01-101-3/+5
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* games-util/xgamer: treecleanJakov Smolić2022-12-315-73/+0
| | | | | Closes: https://bugs.gentoo.org/821118 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
* games-util/pyfa: treecleanJakov Smolić2022-12-207-250/+0
| | | | | Closes: https://bugs.gentoo.org/848600 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
* games-util/sc-controller: drop 0.4.8.6_p20211211Ionen Wolkens2022-12-193-89/+0
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* games-util/grfcodec: drop 6.0.6_p20210310Ionen Wolkens2022-12-191-41/+0
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* games-util/joycond: Bump snapshot to 20220720. drop old 20210730James Le Cuirot2022-12-082-2/+2
| | | | Signed-off-by: James Le Cuirot <chewi@gentoo.org>
* games-util/joycond: Allow /dev/uinput in systemd unitJames Le Cuirot2022-12-081-2/+3
| | | | | Closes: https://bugs.gentoo.org/867385 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
* games-util/lutris: remove unused patch(es)Michael Mair-Keimberger2022-12-061-92/+0
| | | | | | Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/28573 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
* games-util/game-device-udev-rules: Apply patsub_replacement defencesKerin Millar2022-12-061-1/+1
| | | | | | | | | | | | | | | | | Per bug #881383, string replacing forms of parameter expansion must take care to quote - or appropriately escape - any nested parameter expansions, assuming that their values are intended to be taken literally (as is almost invariably the case). This has long been the case, but the introduction of the new patsub_replacement option in bash >=5.2 has brought the issue to the fore. In the case of the games-util/game-device-udev-rules package, the improper quoting is not yet causing any issues. Still, it is better to write the code properly to begin with, especially considering the demonstrative value of robust code. Signed-off-by: Kerin Millar <kfm@plushkava.net> Bug: https://bugs.gentoo.org/881383 Signed-off-by: Sam James <sam@gentoo.org>
* games-util/lutris: drop 0.5.10.1, 0.5.12_beta1Andrew Ammerlaan2022-12-023-168/+0
| | | | Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
* games-util/lutris: add 0.5.12Andrew Ammerlaan2022-12-022-0/+82
| | | | Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
* games-util/lutris: update 9999Andrew Ammerlaan2022-12-021-2/+2
| | | | Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
* games-util/xpadneo: stabilize 0.9.5 for amd64Ionen Wolkens2022-12-011-1/+1
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* games-util/libstrangle: fix BetterCompressionUriIonen Wolkens2022-12-012-2/+2
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* games-util/antimicrox: bump to 3.3.2Maciej Barć2022-11-212-0/+75
| | | | Signed-off-by: Maciej Barć <xgqt@gentoo.org>
* games-util/antimicrox: drop old 3.3.2_rcMaciej Barć2022-11-212-76/+0
| | | | Signed-off-by: Maciej Barć <xgqt@gentoo.org>
* games-util/antimicrox: bump to 3.3.2_rcMaciej Barć2022-11-192-0/+76
| | | | Signed-off-by: Maciej Barć <xgqt@gentoo.org>
* games-util/lutris: drop dependency on net-libs/libsoupAndrew Ammerlaan2022-11-172-2/+0
| | | | | Closes: https://bugs.gentoo.org/881565 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
* games-util/xboxdrv: fix binpkg installation, udev_reload, add python3_11John Helmert III2022-10-291-0/+83
| | | | | | Closes: https://bugs.gentoo.org/776601 Closes: https://bugs.gentoo.org/859325 Signed-off-by: John Helmert III <ajak@gentoo.org>
* games-util/antimicrox: bump to 3.3.1Maciej Barć2022-10-242-0/+75
| | | | Signed-off-by: Maciej Barć <xgqt@gentoo.org>
* games-util/pyfa: align longdescription opening and closing tagsPetr Vaněk2022-10-201-5/+5
| | | | | Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: Sam James <sam@gentoo.org>
* games-util/lutris: add version 0.5.12_beta1Andrew Ammerlaan2022-10-194-2/+178
| | | | | Closes: https://bugs.gentoo.org/876807 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
* games-util/sc-controller: Version bump to 0.4.8.9James Le Cuirot2022-10-132-0/+53
| | | | | Closes: https://bugs.gentoo.org/876733 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
* games-util/slade: Fix patch with broken whitespaceJames Le Cuirot2022-10-081-16/+16
| | | | | | | Sorry, my editor must have mangled it. Closes: https://bugs.gentoo.org/865871 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
* games-util/grfcodec: update EAPI 7 -> 8David Seifert2022-10-083-0/+247
| | | | | | Bug: https://bugs.gentoo.org/715910 Bug: https://bugs.gentoo.org/859310 Signed-off-by: David Seifert <soap@gentoo.org>
* games-util/gamemode: Drop old 1.6.1James Le Cuirot2022-10-013-168/+0
| | | | Signed-off-by: James Le Cuirot <chewi@gentoo.org>
* games-util/gamemode: Don't build utils for the non-native ABIJames Le Cuirot2022-10-012-0/+4
| | | | Signed-off-by: James Le Cuirot <chewi@gentoo.org>
* games-util/xpadneo: drop 0.9.4Ionen Wolkens2022-09-272-75/+0
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* games-util/libstrangle: enable abi_x86_32 by defaultIonen Wolkens2022-09-221-6/+2
| | | | | | | | | | | | Similarly to what's done for wine and friends, unsure why haven't done this in the first place considering this has no further multilib deps (this doesn't link with any libraries in DEPEND, what this uses will depend on what applicates/games are linked with themselves). Remove warning too, assume anyone manually turning it off would know what they're getting into. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* games-util/libstrangle: rdepend on glibc[hash-sysv-compat]Ionen Wolkens2022-09-201-1/+8
| | | | | | | | | | Not closing bug #863863 yet given this isn't due to be a permanent solution. If steam/wine issues are resolved and this is the only package needing this, will look at other workarounds if upstream hasn't done anything yet. Bug: https://bugs.gentoo.org/863863 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* games-util/deutex: Keyword 5.2.2 arm64, #849866matoro2022-09-191-2/+2
| | | | | Signed-off-by: matoro <matoro@users.noreply.github.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
* games-util/xpadneo: add 0.9.5Ionen Wolkens2022-09-172-0/+75
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* games-util/lgogdownloader: remove boost slot depsDavid Seifert2022-09-042-3/+3
| | | | Signed-off-by: David Seifert <soap@gentoo.org>
* games-util/antimicrox: add missing ECM dependencyMaciej Barć2022-09-021-0/+1
| | | | | Closes: https://bugs.gentoo.org/867997 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
* games-util/antimicrox: add missing qtconcurrent dependencyMaciej Barć2022-09-021-0/+1
| | | | | Closes: https://bugs.gentoo.org/867970 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
* games-util/antimicrox: new package; add version 3.2.5Maciej Barć2022-09-024-0/+99
| | | | Signed-off-by: Maciej Barć <xgqt@gentoo.org>
* games-util/lutris: drop 0.5.11_beta1Andrew Ammerlaan2022-08-262-83/+0
| | | | Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
* games-util/lutris: add 0.5.11Andrew Ammerlaan2022-08-262-0/+84
| | | | Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
* games-util/gamemode: fix build w/ glibc 2.36Sam James2022-08-242-0/+21
| | | | | Closes: https://bugs.gentoo.org/863995 Signed-off-by: Sam James <sam@gentoo.org>
* games-util/slade: Unbundle fmt library, fixing broken SONAMEJames Le Cuirot2022-08-162-40/+141
| | | | | Closes: https://bugs.gentoo.org/859322 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
* games-util/lgogdownloader: drop 3.8Ionen Wolkens2022-08-112-40/+0
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>